FO to PDF transformation is changing Arabic characters

I’m using Aspose.PDF for .Net 21.3 to turn XML files into PDFs
We recently noticed some Arabic characters were changed during the PDF rendition:

The Arabic text looks like this in input: الو بيروت
And this is what we’re getting in the PDF: ول توريب

The lines of code I’m using are simply as below:

Dim options As XslFoLoadOptions = New XslFoLoadOptions()

Using pdfGenerated As Document = New Document(foInputPath, options)
End Using

I tried using version 23.8 of Aspose.PDF and I had the same issue

The XML we start from, the FO file generated from it and the output PDF file are in the folder I uploaded. We can see the Arabic characters look fine in the XML and FO files but not in the PDF

Arabic characters (42.8 KB)

Thanks in advance for your support


What version did you try upgrading to?
23.8 is not out yet. The newest one is 23.2.

Can you try Aspose Pdf 23.2, please, and let me know how it goes?

Hi @carlos.molina,

Sorry I meant to say 23.1.1 not 23.8. I just tried again using version 23.2 and I have the same issue

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): PDFNET-53736

You can obtain Paid Support Services if you need support on a priority basis, along with the direct access to our Paid Support management team.

1 Like

Thanks @carlos.molina

Do you have a rough idea of how long it could take for this issue to be fixed? I know you’re operating on a “first come, first served” basis but I have no visibility on how many tickets are queued before this one :slight_smile:

We’d like to know if we should be expecting months or years


Sadly, that’s another team and they have their own strategies and estimations, which I do not know.

All I can say is if it is an issue that is affecting many users, then it takes priority, or if you do pay for support.

Besides that, I cannot tell you anything else, sorry.