We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Form field font size issue

We’re using Aspose PDF to populate form fields and seeing some strange behavior. After opening a populated PDF, we’re seeing that the font size of the form fields is very small, but clicking into a field causes the font size to jump to a larger size. Clicking out of the field returns it to a small size. Editing a field causes it to stay at the larger, correct size, but this of course is not an option. They need to be programmatically populated without this issue. We’ve tried setting the fields to a specific font size, setting them to “auto” size, setting FitIntoRectangle to true/false, nothing seems to correct this issue.

Trying a competitors product, we’re not seeing this issue and all fields are populated correctly and retain the correct font sizing. Sine we have an Aspose PDF license, we’d like to stay with Aspose, but we need this issue resolved.

form field font size issue example.pdf (273.6 KB)

@RobertKeifer

To ensure a timely and accurate response, please attach the following resources here for testing:

  • Your input PDF document.
  • Please create a standalone console application (source code without compilation errors) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we will start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.

Here are the resources you requested. Running the app just populates the form fields with their field names, but it’s enough to see the issue. I’ve included one I ran myself with our Aspose PDF license. “Form Fields Test Doc_FILLED_BY_RK.pdf”

AsposeTest.zip (185.3 KB)

@RobertKeifer

We have logged this problem in our issue tracking system as PDFNET-51967. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

1 Like

The issues you have found earlier (filed as PDFNET-51967) have been fixed in Aspose.PDF for .NET 22.9.

A post was split to a new topic: Form field font size is changed after adding some text