We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Form Field not showing on Mobile Device [product : Aspose.pdf for .net]

Hello Support Team,

The form field appears correctly on a PC in Acrobat Reader, however they do not appear on iPad and Android devices [any mobile devices].

Please tell me if Aspose.pdf for .net product support this, if so is there any instruction on documentation how to solve this problem.

thank you

mehul patel

Hi Mehul,


Thanks for contacting support.

I have tested the scenario where I have created a PDF form using Aspose.Pdf for .NET 7.7.0 which contains one text field and when I have tried viewing the file in Adobe Reader over iOS 5.0.1, I am able to see the form field. However when I have tried using the default file viewer and iBooks, the filed does not appear. The problem seems to be related to default viewer of iOS. For your reference, I have attached the PDF file which I have tried viewing. Please take a look.

Please share the name of application which you are using over Android platform. We are sorry for your inconvenience.

Thank you for getting back to me support team,

I am using Aspose.pdf version 6.7.0.0 .

Does it has to be version 7.7.0 or it can be different version.

Please let me know.

thank you

Mehul Patel

Hi Mehul,


In my previous attempt, I have tried using Aspose.Pdf for .NET 7.7.0. Please try using the latest release version and in the event of any further query, please feel free to contact.

Hello,

Does it mean I have to pay for the newer version of .DLL ?

Or I can just download it and use it that way.

thank you

mehul patel

Hi Mehul,


Aspose.Pdf for .NET 7.7.0 was released on 07-February-2013 and if your license subscription allows you upgrades to product released by 07-February, then you should be able to use this new version. In case your license is not valid, you may download the product release and try using the component in trial mode.

If all the issues are found fixed, you may proceed with license upgrade.

PS, The trial version provides the same set of features as offered by licensed version except for the fact that the output generated with trail mode contains an evaluation watermark which does not appear when using the component in licensed mode.

We are using Aspose pdf 8.0 and we are having the same issues. The form fields are displaying correctly on desktop, however, form fields are not displaying on iPad and iPhone. Please advise. Thanks!

Hi,


Thanks for contacting support.

I have tested the scenario using Aspose.Pdf for .NET 9.3.0, where I have used the following code snippet to create a PDF form containing one text field and as per my observations, its properly appearing when viewing the file in Adobe Reader App and PDF Expert App over iOS 5.0.1. For your reference, I have also attached the resultant PDF generated over my end.

Can you please share the code snippet which you are using to generate the file and also please share the sample PDF files causing this problem, so that we can double check the issue at our end. We are sorry for your inconvenience.

[C#]

//open document<o:p></o:p>

Document pdfDocument = new Document();

pdfDocument.Pages.Add();

//create a field

TextBoxField textBoxField = new TextBoxField(pdfDocument.Pages[1], new Aspose.Pdf.Rectangle(100, 200, 300, 300));

textBoxField.PartialName = "textbox1";

textBoxField.Value = "Text Box";

Border border = new Border(textBoxField);

border.Width = 5;

border.Dash = new Dash(1, 1);

textBoxField.Border = border;

textBoxField.Color = Aspose.Pdf.Color.FromRgb(System.Drawing.Color.Green);

//add field to the document

pdfDocument.Form.Add(textBoxField, 1);

//save modified PDF

pdfDocument.Save(“c:/pdftest/Sample_output.pdf”);

Here it is:

using (var pdfForm = new Form())<?xml:namespace prefix = "o" ns = "urn:schemas-microsoft-com:office:office" />

{

pdfForm.BindPdf(inputFile);

pdfForm.FillField("Name", Name);

pdfForm.FillField("Add1", Add1);

pdfForm.FillField("Add2", Add2);

pdfForm.FlattenField("Name");

pdfForm.FillImageField("BarCode", BarCodeStream);

var pdfStream = new MemoryStream();

pdfForm.Save(pdfStream);

return pdfStream;

}

}

The only field that will show up on the iPhone (with iOS 7) is the Name field, and I use FlattenField to make it a read-only field. Does it have anything to do with it? Add1, Add2, and BarCode didn't show when views in iPhone, but they display ok via desktop browser.

Hi,


Thanks for sharing the details.

I have tested the scenario using Aspose.Pdf for .NET 9.3.0 where I have used the following code snippet to create the PDF file and as per my observations, when viewing the file in Adobe Reader over iOS 7.0.3, the form fields are properly appearing. However when trying to view the file in iBooks, the only form field which is flattened is visible. Other two fields are not appearing. For the sake of correction, I have logged this problem as PDFNEWNET-37122 in our issue tracking system. We will further look into the details of this problem and will keep you posted on the status of correction.

Can you please share which application you are using over iOS and experiencing this problem. We will also try replicating the problem in that application. We are sorry for your inconvenience.

I am using iPhone iOS 7.1.1, viewing pdf using iBooks. Please let us know when this is fixed. Thanks for your help.

Hi,


Since we recently have been able to notice this issue, and until or
unless we have investigated and have figured out the actual reasons of this
problem, we might not be able to share any timelines by which this problem will
be resolved.

However, as soon as we have made some significant progress
towards the resolution of this issue, we would be more than happy to update you
with the status of correction. Please be patient and spare us little time. Your
patience and comprehension is greatly appreciated in this regard.<o:p></o:p>

Just FYI, other than iBooks, I also tested using Kindle and axisReader. Kindle had the same issue, no problem with axisReader.

Hi Mehul,


Thanks for the feedback.

We will definitely consider these scenarios during the resolution of this problem.

HI Nayyer,

We are using ASPOSE dll for genrating pdf at enterprise level, it seems to have some issue with iOS default rendering. (PDF comes with pink boxes)

otherwise it comes correct in windows environment.

Let me know if you need some more information on this issue.

Hi Abhijeet,


Thanks for using our API’s.

Can you please share the resource PDF file causing this problem, the code snippet which you are using and application which you are using to view the file on iOS, so that we can further test the scenario in our environment.

We are sorry for your inconvenience.