We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Formatting Issues Generating PPTX from Template

Hello,


I am using Aspose Slides v6.8 and attempting to create a PPTX by reading a template into a MemoryStream. I’m able to do this and generate the PPTX but find that the formatting is completely destroyed with text appearing diagonal outside the slide that should appear in specific areas on the slide. I’ve tried various methods and finally in frustration just tried just reading in a PPTX and simply writing it back out and still find that the text gets knocked outside the slide.

I’m attaching two images to show what is going on. The first “Sample Input.png” is an obfuscated version of the original PPTX I’m reading in with red boxes showing the text items in question. The second “Output.png” shows the PPTX generated by Aspose with the text diagonal outside the slide. Additionally the image is gone, though I’ve found if I manually apply a Layout in PowerPoint then the text goes back into place, the picture reappears, but then there are a myriad of other alignment issues that appear (I won’t get into that here).

Can anyone provide me with any help on this matter? I’ve been trying to resolve this for days and still no closer to a solution.

Thank you very much!

Hi Chris,


Thank you for your interest in Aspose.Slides.

I have observed your comments and like to request you to please try using Aspose.Slides for .NET 15.6.0 on your end as it the latest version of Aspose.Slides for .NET with many bug fixes as compared to the version which you are using on your end, also the support is available on basis of latest available version.

Please let us know if the issue persists. We will be happy to assist you further.

Best Regards,