Free Support Forum - aspose.com

Gdiplus.dll missing when words to pdf

Hi everyone! I’m trying to convert an edited .words file to pdf via my unity app.

As the doc says I’m using doc.Save(“myDoc.pdf”);

However I receive this error message :

DllNotFoundException: gdiplus.dll
System.Drawing.GDIPlus…cctor ()
Rethrow as TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus
System.Drawing.Image.InitFromStream (System.IO.Stream stream)
System.Drawing.Bitmap…ctor (System.IO.Stream stream, Boolean useIcm)
System.Drawing.Bitmap…ctor (System.IO.Stream stream)
(wrapper remoting-invoke-with-check) System.Drawing.Bitmap:.ctor (System.IO.Stream)
…ctor (System.Byte[] )
. ()
. (System.IO.Stream )
. (. )
. (. )
UnityEngine.EventSystems.EventSystem:Update()

I dragged gdiplus.dll in my assets folder but same issue… Anyone has an idea? Thanks in advance!

Hi there,


Thanks for your inquiry. Please Aspose.Words uses GDI+ to render document pages to images. We have tested Aspose.Words successfully with Mono 2.10.2. However please share your environment details here along with the details to replicate the issue at our end. We will look into it and will guide you accordingly.

Best Regards,

Hi! Sorry for the delay… I not solved my issue yet. gdiplus.dll in my my Assets/Plugins folder, and I can see (exporting the project from unity to android studio) that the .dll is exported. However I still have the issue when I try to save as pdf a words document.


Help! :wink:

Hi there,


Thanks for your feedback. It seems gdiplus.dll does not load on Unity Mac. Please check following post. It seems it is platform specific known issue.


Best Regards,

@Silvering

I’m getting same exception with Aspose.PDF. I want to know your issue is resolved or not. May be it help me to solve my issue.

Thnx.

@nirali21,

We suggest you please upgrade to the latest version of Aspose.PDF for .NET i.e. 18.8 and see how it goes on your end?

In case the problem still remains, we suggest you please create a new topic with complete details in Aspose.PDF forum where you will be guided appropriately. Thanks for your cooperation.

I had tried by upgrading Aspose.PDF 18.8.0 but it don’t work. It works fine with in window but give same error while tried in MAC and Linux.
I have also posted same topic with complete details here https://forum.aspose.com/t/gdiplus-dll-not-found-on-mac-os/181000.

Thnx.

@nirali21,

Please follow your other thread in Aspose.PDF forum for further proceedings.