We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GenBaseR issue becomes critical on Mac


Referring to the thread POST NO : 453365
Hi
We are facing the exactly same issue as faced by Chang i.e we are
getting the same GenBaseR message on Mac whereas it runs perfect on
Windows.Can you tell us what we can do to fix this temporarily till you
release the final fix ? With that I mean loading the font externally or
installing the font on Mac in fonts directory ??


I understand that you have already created the issue SLIDESJAVA-33790.

Please reply ASAP as it has become very critical for our release.

Thanks and Regards
Mohit Garg

Hi Mohit Grag,


I have linked this thread with the issue ID SLIDESJAVA-33790. The issue is in progress and our development failed to reproduce the issue in the environment mentioned over this link. As you are facing the same issue then please share the sample presentation, MAC version along with JDK version with us. If your fonts are working in Windows, you can copy the font folder from Windows to MAC and use following statement in before loading the presentation to load the copied fonts from Windows in MAC without even installing them.

FontsLoader.loadExternalFonts(new String[] “/Library/Fonts”, “/Library/Fonts/Microsoft”});

The path shared can be custom and depend on where you have copied the font directory. You can give a try to this approach as well but I like to add here that FontsLoader failed to work in MAC in case of Aspose.Slides for .NET. Since, Aspose.Slides for Java is auto ported from Aspose.Slides for .NET, it is highly likely that this feature may not work in Aspose.Slides for Java as well.

We are are working over SLIDESJAVA-33790 and request you to please share the requested details so that we can help you further in this regard.

Many Thanks,


Hi Mudassir,


FYI

Mac Version is 10.8.2
Java is JDK 7 update 21
Presentation is not getting generated so can’t really share or in other words its a zero byte file.

If it helps…
I viewed this post of some forum member which says that this problem doesn’t come on Mac 10.6 and 10.7 and only appears in version 10.8.
We have tested our application on two different Mac and found this claim to be true.We didn’t faced any problem on OS X 10.7.5 but GenBasR issue popped up on 10.8.2.

Thanks for your support.

Mohit Garg


Hi Mohit Grag,


Please observe the font file attached, extract and copy in your MAC installation. Then try loading that using Aspose.Slides for Java 7.3.0 with following code. As per our development team, they have not been able to reproduce the issue by using the shared font. Please share your feedback in this regard.

FontsLoader.loadExternalFonts(new String[] “/Library/Fonts”, “/Library/Fonts/Microsoft”});


Many Thanks,


Thanks Mudassir.
It seems to be working with 7.3.0 even though without copying the attached font in fonts directory.

Hi Mohit Grag,


That is appreciable that things working on your end. Please share, if I may help you further in this regard.

Many Thanks,

The issues you have found earlier (filed as SLIDESJAVA-33790) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.