Generating Images from Presentation Slides Takes Long Time/Stuck in Java

we are having issue with aspose-slides java 22.9 version(tested also 23.1 and got same result) on windows10.
We are converting attached slide document to images and while converting second slide it gets stuck. It seems that problem is in embedded word document in there - even if there is not much data it still takes so much time.
There is code sample how we are doing that:

Presentation presentation = new Presentation(inputStream);, false)
          .map(slide -> parseSlide(slide))
private BufferedImage parseSlide(ISlide slide) throws IOException {
return slide.getThumbnail(renderingOptions, new Dimension(
        (int) width,
        (int) height
} (86.8 KB)

Thank you for contacting support.

It will take me some time to check the issue. We will get back to you ASAP.

I reproduced the problem with rendering the second slide.

We have opened the following new ticket(s) in our internal issue tracking system and will deliver their fixes according to the terms mentioned in Free Support Policies.

Issue ID(s): SLIDESJAVA-39114

You can obtain Paid Support services if you need support on a priority basis, along with the direct access to our Paid Support management team.

Please also share the following additional information:

  • JDK version in your app
  • Width and height of images you tried to generate

Thank you.

We are using JDK 17

Here is how we are setting width/height
slide.getThumbnail(renderingOptions, new Dimension((int)3000.0, (int)1687.5))

renderingOptions - used only for retrieving conversion warnings.

Thank you for the additional information. I forwarded it to our developers.

Hi Andrey, is there any update on this item?

I’ve requested plans for the issue from our developers. We will let you know soon.

Could you please check your results using the latest version of Aspose.Slides for Java? With Aspose.Slides for Java 23.8, the problem does not appear on our end.