Free Support Forum - aspose.com

Grid showing up dead (no interactivity- nothing clickable- editable- etc.) on IE screen using Web Developer 2005 Express/C#

I am trying to use the Grid just to test but the grid shows up as nothing more than just colored boxes. None of the interactivity works. Even the height attribute it ignored and it stretches out vertically to an enormous length. I cannot click on any of the grid cells, command buttons, or the sheet selectors, even the evaluation version sheet is non-responsive. In other words, nothing is clickable, typable, etc. When I use VS 2003 it works fine. Does anyone know what is going on?

Help is much appreciated,

T.

By the way, I made the changes given here:

http://www.aspose.com/wiki/default.aspx/Aspose.Grid/WorkWithVWD2005.html

And the grid now sizes correctly and has the button images properly displayed but the interactivity is still at zero. Can't switch sheets, type anything in the cells, select cells, etc.

Help is greatly appreciated.

T.

I seem to be the only one working on this issue. :)

I found ou that even when you follow the "AGWClientPath" directions you follow in the above document, the Grid control still uses the current page path for a bunch of "behavior" style references. So what I did is replace those references with the correct value by overriding the Render event as below. Obviously this is a temporary solution for me and I would still like to see a fix to this or a response from an Aspose staff.

Thanks,

T.

protected override void Render(HtmlTextWriter writer)

{

StringBuilder temp = new StringBuilder();

StringWriter twr = new StringWriter(temp);

HtmlTextWriter wr = new HtmlTextWriter(twr);

base.Render(wr);

temp.Replace(this.TemplateSourceDirectory + this.AppRelativeVirtualPath.Substring(1), "http://localhost/agw_client");

writer.Write(temp.ToString());

}

Hi,

We suggest to create the web site using the "HTTP" option instead of "File System" option. In the "File System" mode, the behavior of the Grid will not be loaded correctly.

Thank you for trying our product.