GridDesktop and CurrencyCulture?


#1

Hello there!
I have this problem, where when I create a preview from an Excel file, the currency format is automatically wrong.

Exactly the problem is as follows:

  • I have a Cell with set format to 15, Culture Czech, Value 1500
  • In Excel It all looks just fine: “1500 Kč”
  • In GridDesktop preview the cell looks all wrong: “Kč1500”, which is incorrect. I suppose that this uses the default Currency format ‘[sign][value]’.

Can I change it anyhow to look as ‘[value][sign]’ ??

Thank you


#2

@Bunnykill,

Thanks for the details,

Could you also provide template Excel file (containing the formatted cell value) and some screenshots to investigate your the issue, we will check it soon. Also give us your environment details (e.g OS with regional settings, etc.). This will help us to evaluate your issue precisely to consequently figure it out soon.


#3

Thank you!
I will be using lightshot for screenshots to make this easier, so please, don’t fear the links.

I am running on Windows 10 pro x64, regional settings: Country - Česká republika; Language - Čeština (http://prntscr.com/n9w47n)

I cannot really provide the full thing, since it’s confidential data, but I can do so if I remove all the cells that are not important to this cause.

Preview (incorrect) - Aspose GridDesktop:


Saved file (correct) - opened in Excel 365:

test.zip (14.9 KB) (excel export)

How exactly do I do this (in C# / .NET btw):
Server app (Aspose.Cells) generates a file with the Czech Culture and sends the stream to client.
Client then receives the stream (MemoryStream) and imports it into the Aspose.GridDesktop object.
Refreshed and loaded. That works fine. But it just does not show the correct format of currency and I am unable to find the settings, or options, or something to set the culture on the GridDesktop


#4

@Bunnykill,

Thanks for the template file and screenshots.

I tested your scenario/ case a bit by simply loading the file into GridDesktop (I even change/set the regional settings to Czech Republic using control panel in os), it works fine as expected, see the screenshot for your reference:

here is my simple line of code:
e.g
Sample code:

gridDesktop1.ImportExcelFile("e:\\test2\\test.xlsx");

I am using latest version/fix: Aspose.Cells.GridDesktop v19.3.x (please try it if you are not already using it). If you still find the issue with latest version, kindly do create a simple application (WinForm), zip the project and post us here, we will check it soon.


#5

Thank you …
I have more information for you regardless

My code basically looks like this:

MemoryStream FileExcel_ => comes from server, and is inserted in this function:

            gdAsposeView = new GridDesktop();
            gdAsposeView.FinishLoadFile += GdAsposeView_FinishLoadFile;

            try
            {
                WFHost.Child = gdAsposeView;
                (WFHost.Child as GridDesktop).ImportExcelFile(FileExcel_);
            }
            catch 
            {}

I am sorry for not posting the full thing. I cannot.
This is written in WPF, where I use the WindowsFormsHost as WFHost

And I don’t seem to be able to change the way it shows up.
Could it be that importing from stream is different somehow?
Or should I look into the Aspose.Cells on the server?

Where do you suggest the problem could be on? Client or server? This is rather important

I was using 19.1, now I am upgraded onto 19.3, yet I still have the same problem.
I tried to set the wb.Settings.CultureInfo on the server side (Aspose.Cells), but that had no effect on the final preview


#6

@Bunnykill,

Thanks for providing further details.

Yes, the issue might be there. Did you try using my line of code to directly import the Excel file into Aspose.Cells.GridDesktop if you still find the issue.

You may try saving the file to streams via Aspose.Cells APIs then use your own code to import that stream to generate an Excel file if you see the issue with the output file.

If you still could not evaluate, kindly separate the issue and create a simple sample project (runnable), zip the project and post us here to show the issue, we will check it soon.