We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GridWeb display issues

I am evaluating Cells, and I can’t seem to get past adding a GridWeb to a aspx page. The first issue is the lack of any icons displaying in Design view:

image.png (36.2 KB)

and this carries over to what is actually displayed when I run the page (in Chrome):

image.png (14.5 KB)

It displays a little better in MS Edge, but neither Chrome nor Edge has any cell functionality i.e. nothing happens when I right-click a cell.

I am using Visual Studio 2017

@IanMitz,

Could you please try the examples in Aspose.Cells for .NET Examples project and see below documents for your reference:

Integrate Aspose.Cells Grid Controls with Visual Studio
How to Run the Examples

Hope, this helps.

Thank you for your reply.

I had already integrated the Grid controls into Visual Studio, using above instructions.

I did manage to get the icons to display in Visual Studio design view, but only have removing the NuGet package and running the MSI.

But when I run my project, I am still getting the same result that I post in the screenshot above.

I downloaded, compiled and ran the examples, and everything seems to be working correctly with those

@IanMitz,

Thanks for your feedback and using Aspose.Cells for GridWeb.

Please note these settings in web.config file, this is important. Check the red color part. It is the path of acw_client directory which is necessary for GridWeb to work. It contains the acwmain.js and other resource files which are important for Aspose.Cells.GridWeb to work properly. For example, you may add a folder named grid in your project and then add the acw_client directory (you may copy it from your your installation directory, e.g “…Aspose\Aspose.Cells for .NET”). Now add the following lines to web.config file:
i.e.,

<appSettings>
<add key="aspose.cells.gridweb.acw_client_path" value="grid/acw_client/"/>
<add key="aspose.cells.gridweb.force_script_path" value="true"/>
<add key="aspose.cells.gridweb.forcepath" value="true"/>
</appSettings>
.....

Hopefully, this information will help you in sorting out this issue.

If you still find the issue, kindly do create a simple project (runnable) using latest Aspose.Cells.GridWeb v19.1.x with its resource files, zip the project and post us here, we will check it soon.

Hi,
those settings are already in my web.config file.

I will try and create a project and post it later this week.

Ian

@IanMitz,

Please take your time to create a sample project to reproduce the issue. We will be looking forward to get a sample project (runnable), so we could evaluate our issue.