We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GridWeb runFormulas

Hi,

I am evaluating your Cells product for purchase and have been very impressed with the Windows version. I am now trying the ASP.NET version and have found that I do not have an option for runFormulas when I call ImportExcelFile. This is a critical function for me to have. I'm using the latest demo download from your site.

I am also getting a acwmain error. I posted on another thread about it. If I can get these two issues resolved we will purchase the product.

Thanks,
Scott

Hi,

If you setup the GridWeb version correctly, formulas will run.

Please try the sample template project with a single page using GridWeb. It will illustrate how to setup GridWeb and use in your application.

The template project uses the latest GridWeb version:
Aspose.Cells
for GridWeb v2.7.3.2000



Please download it and run it.

Please also do try the GridWeb offline C# demos.

  1. Documentation - Aspose.Cells.GridWeb
  2. Offline C# Demos - Aspose.Cells.GridWeb

Please also see the screenshot that defines how to configure your web.config file.

Screenshot:

Hi,


Well, I think you may use WebWorksheets.RunAllFormulas() method to recalculate all the formulas in the workbook.
e.g
GridWeb1.WebWorksheets.RunAllFormulas();

For other issue about “acwmain error…”, we recommend you to kindly first download and install Aspose.Cells for .NET package v7.1.1 using its MSI Installer:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry360981.aspx
It will also install Aspose.Cells.GridWeb on your machine v2.7.3.2000, now please use this control into your IIS based ASP.NET project.

Also, check the articles:
http://docs.aspose.com/display/cellsnet/Working+With+VS.NET+2005+VWD+2005
http://docs.aspose.com/display/cellsnet/Integrate+Aspose.Cells+Grid+Controls+with+Visual+Studio.NET

Moreover, we recommend you to evaluate and try our offline demos for your further reference:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry294646.aspx
(Check the readme.txt file in the archive)

If you still could not evaluate, kindly create a sample project and post it here, we will check it soon.

Thank you.

Thanks for the quick response. I will try the acwmain fix. But, for the runFormulas I do not want them to run. In windows grid there is an overload method to set runFomrulas to false. I would like to do the same in the webgrid.


Any ideas on how to turn off runFormulas?

Hi,


I am afraid there is no such overload for GridWeb control to cancel the calculations of formulas in the workbook. I have logged a ticket for your request with an id: CELLSNET-40399. We will look into it soon.

Thank you.

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan

@alexands,

We have fixed your issue now. The fixed version will be published in the next few days.

We added GridWeb.IsCalculationFormula attribute that gets or sets whether to calculate formula after cell value changes or after importing file. The default value is true.
e.g.
Sample code:

GridWeb.IsCalculationFormula=false;
GridWeb.ImportExcelFile(filePath);

The issues you have found earlier (filed as CELLSNET-40399) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao