Free Support Forum - aspose.com

Have problem when printing the excel file that saved by Aspose.Cell for Net

I’m coding console line application with .NET3.5 C# and using “Aspose.Cell for .Net 19.12” to convert excel file contents for quickly. The app open a excel “xlsx” file and write contents to file and then save to “.xlsx”. It do really very fast but the file saved by Aspose.Cell have problem when print or export to pdf by Microsoft Excel. Cell border format line was disappeared.
In my attached zip file (ConvertExcelFileTest.zip):

  • FileSaveByMicrosoftExcel: Test convert by “Microsoft.Office.Interop.Excel.dll”. No problem when printing.
  • FileSaveByAspose: Test convert by “Aspose.Cell for .Net 19.12”. Have problem when printing. But if i delete all checkbox ActiveXControl then printing no problem.

Convert excel file source is using japanese “MS 明朝” and have some CheckBox ActiveXControl.

p/s: sorry for my bad english. Please help me
ConvertExcelFileTest.zip (1.4 MB)

@hoactaithien,
I can not notice the issue of cell border format with below code and Aspose.Cells for .NET 19.12.5. Could you please try it and let us know your feedback. Share runnable code snippet as well if your code is different. output.pdf (159.6 KB)

// Instantiate the Workbook object
// Open an Excel file
Aspose.Cells.Workbook workbook = new Aspose.Cells.Workbook(dataDir + "FileSaveByAspose.xlsx");


// Save the document in PDF format
workbook.Save(dataDir + "output.pdf", Aspose.Cells.SaveFormat.Pdf);

Aspose.Cells19.12.5 For .Net2_AuthenticodeSigned.Zip (5.0 MB)
Aspose.Cells19.12.5 For .Net4.0.Zip (5.0 MB)

@ahsaniqbalsidiqui
Thanks for your quickly reply.

the file saved by Aspose.Cell have problem when print or export to pdf by Microsoft Excel

I means After open excel file and save file by Aspose.Cell then open the saved file by MS Excel and print or export to PDF will have problem. Not use Aspose.Cell to export PDF.
In my attached file “Test Steps Clip.zip”:
Step 1. Source folder has a file created by MS Excel. Open it by MS Excel and print to “PrintPage2_Source.pdf” file. Open “PrintPage2_Source.pdf” file display border lines clearly.
Step 2. Run console application that open excel file from [Source] folder and save to [Destination] folder by Aspose.Cell
Step3. Open file in [Destination] folder by MS Excel and print to “PrintPage2.pdf” PDF file. Open “PrintPage2.pdf” file will see some border lines disappreared.

Please check my clip and you will understand.
Test Steps Clip.zip (6.2 MB)

@hoactaithien,
It seems that you have not shared the source folder as the attached zip file contains a single video only. Whereas in the steps to reproduce the issue, you have mentioned console application, Source fodler and destination folder. I have tried to reproduce this issue using the XLSX files (FileSaveByAspose.xlsx and FileSaveByMicrosoftExcel.xlsx) but the issue is not reproduced as those are the output files.

Please share the source template XLSX file along with the sample code which is used to produce the XLSX file in the first post for our testing.

this is my source03.一般仲介用・区分所有建物(敷地権型)(重.No.3).zip (505.5 KB)

//// Open an Excel file
Aspose.Cells.Workbook workbook = new Aspose.Cells.Workbook(@“D:\TEST_EXCEL\Source\03.一般仲介用・区分所有建物(敷地権型)(重.No.3).xlsx”);
//// Save the document in Xlsx format
workbook.Save(@“D:\TEST_EXCEL\Destination\03.一般仲介用・区分所有建物(敷地権型)(重.No.3).xlsx”, Aspose.Cells.SaveFormat.Xlsx);

@hoactaithien,
I am afraid that still I am not able to reproduce this issue. Following steps are performed:

  • Load the sample file into Workbook object
  • Save it back as XLSX in some other folder
  • Open the output XLSX file using Excel 2016 and save it as PDF
  • Open the PDF and compare it with the output PDf shared by you

No issue is observed and output PDF file is OK which is attached here for your reference.
OutputByAspose.pdf (708.3 KB)
OutputByAspose.zip (498.5 KB)

Could you please ensure that you are using latest version of Aspose.Cells for .NET 19.12.5 or not? Also please share your environment details like OS, MS Excel version and any other details which can help us to reproduce this issue.

@ahsaniqbalsidiqui
Thanks for quick reply
I‘m using your above sent dll Aspose.Cells for .NET 19.12.5
I attached related versions. Please check and contact me if you want some more information
WinVer.png (42.4 KB)
ExcelVer.png (25.8 KB)
NetVer.png (343.9 KB)

@hoactaithien,
I have tried this scenario here but still issue is not reproduced. I am sharing the XLSX file created by Aspose.Cells for .NET 19.12.5 in my testing environment here. Could you please try to render it to PDF using Excel in your environment and compare the PDF file with your output PDF file. Also I am sharing the PDF file created by Excel 365 in my environment. Please open it in your environment and share the feedback.
OutputByAspose.zip (498.3 KB)
OutputByAsposeThenExcel.pdf (707.8 KB)

hi @ahsaniqbalsidiqui
I tested your aspose excel file. In the MS Excel if you use “Export” menu of menu File to export PDF file will no problem. But if you use “Print” menu of menu File, and print to paper or print to PDF file you will reproduce my problem.
Please preview my reproduced clip that sent above, you will see i used “Print” menu to print pdf file.

@hoactaithien,
Thank you for providing the feedback.

We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-47087 – Have problem when printing the excel file that saved by Aspose.Cells for .NET

@hoactaithien,

This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@ahsaniqbalsidiqui, @Amjad_Sahi
Thank you for your quick support. I’m waiting for a new version.

@hoactaithien,

Sure, in the next few days (e.g within 5-7 days), you will get Download link to the fixed version.

Keep in touch.

The issues you have found earlier (filed as CELLSNET-47087) have been fixed in Aspose.Cells for .NET v20.1. This message was posted using Bugs notification tool by Amjad_Sahi

My problem was resolved. Thank you so much.

@hoactaithien,
You are welcome.