Free Support Forum - aspose.com

Heading numbering problem

Hello,

I have a problem with the heading numbering, The numbers get out of sequence, my document goes from 2.1 to 6.1. Looking at the xml file it looks to me like the component is formatting bullets as heading and counting these in the sequence.

Any thoughts on how to fix. I tried manually calculating the real number for the heading and putting that in the userlabel attribute with some success, but I now got occasional errors:Invalid index in Segments indexer: 0

Thanks for considering Aspose.

Could u attach the xml file and codes which can reproduce the problem?

BTW, plz check out the wiki page for helpful information.

http://www.aspose.com/Wiki/default.aspx/Aspose.Pdf/SpecifyHeadingLevelAndAutoSequencing.html

Hi Kevin,

Sorry for the delay in responding, I had to check with the client that I could send their research material through.

I have attached the xml file generated. It first goes wrong at the heading "From Telecommunications to Information Highway" it thinks it is numbered 4.1 it should be 5.2.

Our code builds a table of contents from the heading levels on the website, the other numbers you'll see in a different segment is our code writing it what we think is the correct heading number

Thanks for considering Aspose.

I 've reproduced the same error and try to fix it up.

BTW, could u provide the Word document? It will help us to locate reasons quickly.

Thanks for your coorperations.

here is the document

Thanks for considering Aspose.

We checked the xml file and found this problem is caused by Aspose.Words. You can find "UserLabel="4.1"" directly in xml which produced the error. I will move this post to Aspose.Words forums and they will give you an approving solution

Best Regards.

cool, how does that work, do they email me, or do I need to keep monitoring a new thread?

Please keep your attention on this thread.

Hi Andrew,

Thanks for reporting this problem to us.

I have logged it to our defect base as Issue #953. We will be able to deal with it in the next 2-3 weeks. I will inform you of the results here in this thread.

Best Regards,

The issue is fixed in Aspose.Words 3.6. Headings in the attached document are converted correctly now.