Free Support Forum - aspose.com

Hidden column visible after rendering

I have a report with at tablix, built using SSRS 2008. I have an expression to hide a column if the column header has a length of 0. When I render the report using the SSRS built in Excel renderer, the hidden column stays hidden and everything displays correctly. When I use the Aspose.cells renderers, either xls or xlsx, the hidden column becomes visible and the data values in one row are missing. I have attached the .rdl file. Any help or suggestions are greatly appreciated.

Hi,

Thanks for considering Aspose and reporting this issue.

Please also test your issue with the latest version https://downloads.aspose.com/cells/reportingservices and let us know your feedback.

Where should I be putting the new dll file? I have updated the dll file in the following path C:\Program Files\Aspose\Aspose.Cells for Reporting Services\Bin\SSRS2008


After putting the new dll in that folder, I re-ran my report and I am still having the same issue. Should I be updating the dll in a different location?

Hi,

Please copy the dll at the following folder:

${SQL Server for Reporting Services} \Reporting
Services\ReportServer\bin

The issues I ran into before were during my development and happened when I rendered my report from within Visual Studio. I have completed my report development and am now running the report from Report Manager. I have run into some new issues rendering the report using the Aspose xls and xlsx file formats. When I export my report as Aspose xls or xlsx the appropriate file is created but when I open it I receive the following

"Excel found unreadable content in ‘CrossTabPermissionMatrix(1).xlsx’. Do you want to recover the contents of this workbook? If you trust the source of this workbook, click Yes"
After clicking yes the file opens I receive another message that says
“Excel was able to open the file by repairing or removing the unreadable content.”

"Removed Records. Merge cells from /xl/worksheets/sheet1.xml part"

When I look at the resulting spreadsheet my first two columns have been deleted from the file starting on row 8, where the actual data of my report begins.

When I render my report using the built in Excel renderer the report renders correctly. This is all being run on my local machine running XP pro and SQL 2008

Any suggestions?

Hi,


Please use the latest version of the product e.g please download and try the version posted/attached in the post in this thread:
http://www.aspose.com/community/forums/permalink/339706/333902/showthread.aspx#333902

If you still find these issues, kindly attach your sample RDL file and output Excel file here, we will check your issue soon.

Thank you.

I have applied the new dll as instructed and am still having the same issue. I have attached the rdl file, a xls file rendered using the SSRS built in Excel renderer and a xlsx file rendered using the Aspose xlsx renderer.

Hi,

Thanks for your files and testing it with latest version. We have added this issue in our database. We will investigate it and fix it asap.

This issue has been logged as SSRS-40001.

Hi,

We have tested your provided report define file.

Exported report file is normal.

Please try the latest version v1.7.0.58(attached) for SSRS 2008.

Please refer to update in the following ways.

1. For Visual Studio 2008, please copy Aspos.Cells.ReportingServices.dll into following folder:${Microsoft Visual Studio 9.0}\Common7\IDE\PrivateAssemblies.
2. For Server SQL 2008 for Reporting Services, please copy Aspos.Cells.ReportingServices.dll into following folder:${SQL Server for Reporting Services} \Reporting Services\ReportServer\bin .
3. Please check Aspose.Cells.ReportingServices.dll version after updating.
4. Reload Aspose.Cells.ReportingServices.dll.

We are attaching here the exported Excel file. Please check it out.

Thank you.

the source of my issue was having an expression on the hidden property of my column group. When I removed that expression and set it to always show, the report renders correctly.

Hi,

Thanks for your feedback.

We have found this issue and we will fix it asap and update you.

Hi,

Please try the fixed version v1.7.0.59 (attached) for SSRS 2008.

I have applied the new dll and I am no longer receiving errors when I render a report. But, merged cells are being unmerged and that is messing up my report formatting.

Hi,


Could you attach your exported Excel file, also attach the source RDL file here. We will look into it soon.

Thank you.

Hi,

Please let us know how many cells are in your exported excel file.

When cells number are more than default value(1,000,000), merged cells will un-merge.

Please refer follow context to set LimitCellsNumberForMerged value in Aspose.Cells.ReportingServices.xml file.

==============================================================================================================

















===============================================================================================================


The issues you have found earlier (filed as SSRS-40001) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Hi, We are facing thsi problem as well. W ehave an excel exported using SSRS on which we use Aspose.cells to perform Zoom settings . The collapsed columns in SSRS Export are automatically expanded on proceesing through Aspose.cells.
The expansion happens automatically as soon as the workbook is initialized
Workbook workbook = new Workbook(reportInfo.FullName);

Here are the details from wath where 0.0 width is expanded to a random value of 8.42…

GroupLevel 0 byte
Index 3 int
IsHidden FALSE bool
Style {Aspose.Cells.Style} Aspose.Cells.Style
Width 8.428571429 double

Hi,

Thanks for your posting and considering Aspose.Cells for Reporting Services.

Please create a separate thread with good detail of your issue. And also provide screenshots (if relevant), rdl file and exported excel file. We will look into your issue and log it in our database for a fix. Thanks for your cooperation.