We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Hidden lines not removed when DXF converted to PDF

I have a DXF which when converted to PDF does not hide the ‘hidden’ lines. When I view the DXF in AutoCAD or other CAD application it shows properly. When I convert to PDF using Aspose.CAD it shows the extra lines that should be hidden.

What am I missing?

@Jaimesh

Attached please find the view of the file that is from AutoDesk. Can you please share a comparison snapshot that what hidden elements are being rendered by Aspose.CAD. Moreover, please also share that which API and version you are using on your end along with possible sample code that you have tried.

Image_cad.png (254.7 KB)

Hi Mudassir,

Below i have attached image to show comparision of DXF file and Aspose generated PDF output.

You can downlaod below zip file which contain visual studio 2017 solution (console applicarion which i have used to convert dxf file) and sample dxf file.
Visual Studio 2017 Solution and sample DXF file

DXFOutput_compare.png (16.6 KB)

Hi Mudassir,

A quicker response would be appreciated.
The issue has become urgent for us as we have lost lot of time on this already.

@Jaimesh

I have tried exporting the DXF shared using 2 online tools (zamzar & cloudconvert) and Aspose.CAD. The results are identical. Can you please provide the desired output PDF that you have generated using some other tool so that we can make a comparison.

cloudconvert_Q_Q0064.pdf (40.1 KB)
zamzar_Q_Q0064.pdf (57.3 KB)
AsposeSaved2.PDF (387.7 KB)

@mudassir.fayyaz

See attached PDF generated from Autodesk DWG TruView 2021 and also settings with which it was generated.
Aspose should generate similar, with hidden lines removed.Autodesk DWG TruView 2021-Q_Q0064.pdf (1.1 MB)

Autodesk DWG TruView Plot settings.png (30.1 KB)

I am not sure why you are comparing outputs with other online converters?!

@Jaimesh

Thank you for sharing the information. A ticket with ID CADNET-8245 has been created to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once issue will be fixed.

@mudassir.fayyaz, Thanks for the update.

Any estimates on by when this will be fixed?

@Jaimesh

It has just been logged in our issue tracking system and I request for your patience. I will share updates with you as soon as the issue will be fixed.

@mudassir.fayyaz
Any update?

@Jaimesh

At present the issue is still unresolved. We request for your patience and will share good news with you as soon as it will be addressed.