Free Support Forum - aspose.com

How to enable vertical scroll bar in Aspose GridWeb (Aspose.Cells.GridWeb Version 2.5.1.2000)

Hi Technical Team,

I tried several ways to enable vertical scroll bar, but its not working.

Method1:(tried using this property but vertical scroll is not enabled)
NoScroll=false;
NoVScroll=false;

and another query . I’m not able to freeze column and row together. while freezing merged column alone works fine and again freezing merged row alone ,it works fine. If I try to freeze both merged column and row , the row gets freezed and the merged column is not freezing.


Method1:

g.WebWorkSheets[0].FreezePanes(1,1,1,8);(Row freeze for merged column)
g.WebWorkSheets[0].FreezePanes(1,1,10,1);(column freeze for merged column)






Hi,

I suggest you give it a try to our latest fix release of Aspose.Cells.GridWeb v2.5.2.2002. If your problems persists then provide us a simple project showing your issues. We will look into that real soon.

Regarding the problems you are facing,

Scroll Problem:
By setting the GridWeb.NoScroll to false will show/enable both scrolls and vice versa.
Freezing Problem:
I guess you have already seen our online demos for Apsose.Cells.GridWeb. If not, then please check the below link for demo showing the Freeze Pane functionality,
http://www.aspose.com/demos/.net-components/aspose.cells/csharp/grid/common/freeze-pane-custom.aspx

Thanks

Hi,

I tried using Aspose.Cells.GridWeb v2.5.2.2002 and enabled NoVscroll and NoScroll to false. But Vertical scroll bar is not enabled. I’ve attached a sample coding . Can you please check this for me .



Thanks,
Assal

Hi,

We checked your default2.aspx, we found you are using XhtmlMode=“false” and the doc type is

<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>

You should set XhtmlMode=“true”, the vertical scroll bar works fine.

Hi,

Thank you so much vertical scroll bar is now enabled,but after removing “<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>” this line all my three Ajax modalpopupwindow is not displaying in the center of the screen, which was working perfectly before removing that.

Ajax needs “
<!DOCTYPE html PUBLIC “-//W3C//DTD XHTML 1.0 Transitional//EN” http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd”>” this line to display modalpopupwindow in the center. Can you please suggest me what type of DOCTYPE to be used.


Many Thanks,
Assal


Hi,

Well, you only need to set the XHtmlMode attribute to set to “true”, you can have your existing <DocType…>. You do not need to delete or change your existing <DocType…>. And, we actually did not recommend you to remove or change the <DocType…> either.

Hi,
If I use my then vertical scroll bar is disabled. Only when I remove the my vertical bar is enabled. Please find the attached sample code(Default2) and can you please reply me.


Many Thanks,
Assal.

Hi,


We have tested your provided project with IE6, IE7, IE8 and Firefox. In all cases vertical scroll bar is working fine. Which web browser are you using?
If you are facing difficulties, then please provide us snapshots of the issue. We will further look into the problem.
Thank you.

I tested my sample project in IE8 and FireFox. It is showing different result for different browser for me. Can please check the attched word document,i’ve screenshot of my result. Please reply me back

IE8
With using ,XhtmlMode=“True” vertical scroll bar is disabled,
Without using ,XhtmlMode=“True” vertical scroll bar is enabled

Firefox
With using ,XhtmlMode=“True” vertical scroll bar is disabled

Without using ,XhtmlMode=“True” vertical scroll bar is disabled

Hi,
Have you got any solution for this. Its quiet urgent.

Many Thanks,
Assal

Hi,

We have logged this issue in our database. Our developers will investigate the issue and we will update you asap. Thanks for your patience.

This issue has been logged as CELLSNET-27790.

Hi,

We checked your screen shots, we found you are using web application not an IIS website.

Please copy “acw_client” folder with files (according to Aspose.Cells.GridWeb v2.5.2.2002) into your project, and add these configurations into appSettings section in your web.config:








Your project works fine in IE8 and FireFox with using ,XhtmlMode=“True”.