We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

How to highlight tab in xsl converted to html

Hi. Highlight

I am using Aspose.Cells I convert .xsl file with tabs to Html.

Aspose.Cells.Workbook wb = new Aspose.Cells.Workbook(contentStream);
wb.Save(resultFileName, Aspose.Cells.SaveFormat.Html);

Tabs is displayed and work correctly but if I have many tabs i cant see which one is active now. It is possible to make active tab selected for user? And how can i do so?

Thanks in advance.


By default, if you are not using/setting license (in your code), the evaluation worksheet would always be made active in the output files. Also, if you are using or setting license with your valid license, the default active sheet in the Excel file would be made active in the output file. Please see the document/article on how to get / set or activating worksheet in the workbook:

Let us know if you still have any confusion or issue.

Thank you.
Hi Amjad.

Thank you for your reply.
But my issue not really in programical setting of active tab.
The step is like this :
- I am conveting .xls file with several worksheets to .html with Aspose.Cells version;
- open resulting html file and find that tabs for worksheets are the same;
- trying to click on that tabs, worksheets switching correctly but tabs are the same.
The thing is if I will convert xls document with multiple worksheets I would be unclear which one I select after several clicks.

Important thing - tabs in IE8- IE10 highlighted when I switch worksheet but not in Opera and Chrome.

The code which I am using for convert:

Aspose.Cells.Workbook wb = new Aspose.Cells.Workbook(contentStream);
wb.Save(resultFileName, Aspose.Cells.SaveFormat.Html);

File which i am using for test in attachment

Thanks in advance


Well, this is the behavior of Google Chrome or Opera etc. and nothing to do with the product, the issue is not linked with Aspose.Cells component. For confirmation, please open your Excel file into MS Excel and then Save is As “Web Page” to generate the html file manually. Now open the file in Google Chrome browser, you will see the similar behavior for the tabs which are not highlighted at all unlike IE which makes it a bit.

Thanks for your understanding!


Thanks for your reply. I checked it just like you describe and now see that this problem not linked to aspose.

Thank you.


Thanks for your confirmation.

Feel free to contact us any time if you need further help or have any other issue/query, we will be happy to assist you soon.

Thank you.