HTML Body not correctely displayed


#1

Hello,

I worked with the 6.9 Apose.Email version for .Net and I detected an issue when using the ‘Save’ method from ‘MapiMessage’ (HTML Format).
The email content is not displayed at all.
I decided to migrate to the last Apose.Email version (19.9).
I seen some ameliorations but it’s not displaying all the email content.

Is there any property I have to set for showing all the formated content in the email body message?

Thanks and regards,
Flauch


#2

Hello,

I uploaded the program code I used for the test: aspose-smtp-tester.zip (7.5 MB)

Thanks and best regards,
Flauch


#3

@Flauch,

I have observed the issue shared by you and tried using the sample project on my end. While following the steps, I am unable to know what URL to be set as in case of Pic3.png. Can you please share these details. I also request you to please share the detail of issue incurring on your end while using latest API.


#4

Hello,

Thank you for your answer.

The URL should be your Stmp Host.
For the 6.9 version, I have an empty body displayed.
Whereas the 19.9 version display a part of the content.

Do not hesitate if I can help you to reproduce the problem. Thanks for your help.

Best regards,

Flauch


#5

Hello,

After analysis, I discovered which is the real problem.
I succeeded to isolate the issue. I splitted my email content several time to find the part where the issue raised.
To reproduce the issue:

  • The body needs to contain ‘u’ tags with attributes (like ‘style’ in my example)
  • Use ‘MapiMessage’ object and save as ‘.msg’ (SaveOptions = DefaultMsgUnicode or DefaultMsg)

I checked for others SaveOptions, and the issue is not present.

Best regards,
Flauch


#6

@Flauch,

It’s good to know things are resolved on your end. Please share with us if we may help any further in this regard.


#7

@mudassir.fayyaz

The problem isn’t solved. If it is not reproduced with other SaveOptions, we still encounter the error using DefaultMsgUnicode, which is needed on our ends.

To summurize, when using SaveOptions as DefaultMsgUnicode (or DefaultMsg) and sending a mail having a body containing a u tag with style, we always run into this error.

Could you please help us identify where the problem might be coming from?

Best regards,
Flauch


#8

@Flauch,

Thank you for sharing the elaboration of the issue. An issue with ID EMAILNET-39600 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.