We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

HTML formatting and table of contents not working

Hi,

i have a SSRS 2008 R2 report and evaluating Aspose.Pdf for one of our clients.
Unfortunately 2 features aren’t working my clients needs most:

  1. I want to use html table within a textbox(textbox 4). I set the textbox to ‘Interpret html tags’ but the output does not show a table.
  2. I want to use a table of contents within the report output. I added the custom properties to textbox 2 and textbox 4, but i do not know how i can insert the table of content into the report.

Attached please find the text report. Can you give ma a hint?

Kind Regards

Claus

Hi Claus,


Thanks for using our products and sorry for the delayed response.

Please visit the following links for required information on


In case you still face any problem, please feel free to contact.

Dear Nayyer,

thank you for the Information and the links to your documentation. I tried to follow all instructions, but still got problems.

1) Html table object in textbox4 is still not displayed as html table. I already have configured the IsHtmlTagSupported Parameter in reportserver.config. If i additionally create a IsHtmlTagSupported report parameter, the report will be exported with 0 Bytes. If i delete the report parameter the Report is exported correctly.

2) I integrated the IsListSectionSupported report parameter and i got a table of contents. But the content of the textBox is displayed instead of the custom property title. Additionally the table of Content is displyed at top of the report. Can i manually position the toc on page 2 or 3?

Thanks for your Support

Kind Regards

Claus

ClausGolling:
1) Html table object in textbox4 is still not displayed as html table. I already have configured the IsHtmlTagSupported Parameter in reportserver.config. If i additionally create a IsHtmlTagSupported report parameter, the report will be exported with 0 Bytes. If i delete the report parameter the Report is exported correctly.
Hi Claus,

Sorry for the delayed response.

Can you please share the source .RDL so that we can test the scenario at our end.

ClausGolling:
2) I integrated the IsListSectionSupported report parameter and i got a table of contents. But the content of the textBox is displayed instead of the custom property title.

In order for us to test this scenario, we would be requiring the source RDL that you are using. Please ensure that you also share the DataSource referenced in report or you may consider preparing the report based on AdventureWorks database.

ClausGolling:
Additionally the table of Content is displayed at top of the report. Can i manually position the toc on page 2 or 3?

I am afraid currently you can only place the TOC at the beginning of report. However the requirement to place TOC over specific page number is already logged in our issue tracking system as PDFREP-26636. The development team is already working on supporting this feature and as soon as we have made some progress towards its resolution, we would be more than happy to update you with the status of correction. Please be patient and spare us little time.


We are sorry for your inconvenience.

Dear Nayyer,

attached please find the rdl file that i use.

Please notice that i have not integrated any data source because it is not necessary to demonstrate or reproduce the problems.

Kind Regards

Claus

Hi Claus,


Sorry for the delayed response. We are looking into your query and will update you soon.

Best Regards,

ClausGolling:
1) Html table object in textbox4 is still not displayed as html table. I already have configured the IsHtmlTagSupported Parameter in reportserver.config. If i additionally create a IsHtmlTagSupported report parameter, the report will be exported with 0 Bytes. If i delete the report parameter the Report is exported correctly.
Hi Claus,

Thanks for sharing the resource file.

I
have tested the scenario and I am able to notice the same problem. For the sake
of correction, I have logged this issue as PDFREP-33271 in
our issue tracking system. We will further look into the details of this problem
and will keep you updated on the status of correction. Please be patient and
spare us little time. We are sorry for this inconvenience.<o:p></o:p>