We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

HTML to EXCEL convert failed with error Invalid '#'

there is another thing we noticed recently:

  • when converting HTML to Excel we always get the failed error as
    • Convert failed - com.aspose.cells.CellsException: Invalid ‘#’(Based on Name Team Self-Assessment!print_area)
    • Convert failed - com.aspose.cells.CellsException: Invalid ‘#’(Based on Name BCM_NOK_poziomo!print_area)
  • we tried the same file with your online converter, we get the same error
    Snag_228bcd6d.png (114.4 KB)
  • This seems to cause by the Unicode recognition problem($ symbol i think)
    Thanks for advance.

@FSUPTC
We have found your mentioned and log it with issue Id CELLSNET-52556.

@FSUPTC,

We are pleased to inform you that your issue has been resolved now. The fix will be included in our upcoming release (Aspose.Cells v23.2) which is scheduled in the first half of February 2023. You will be notified once the next release is published.

Thanks for all your help, can we know the release date for this one?

@FSUPTC,
The release version(Aspose.Cells v23.2) is scheduled in the second week of February 2023.

Thanks for the info, just in case, we are using aspose.cells for JAVA, do you think this fix will be available/included as well?

@FSUPTC,

Generally, we fix issues in .NET APIs first and then include fixes in Java version (source code is ported from .NET codebase) in parallel. We will also fix the issue in Java release.