Free Support Forum - aspose.com

Hyperlinks in PDF and HTML

Hi,

saving the attached document to PDF and HTML lost the hyperlink of the shape.

Hi Marc,


Thank you for contacting support. I have tested your sample Visio drawing against the latest build of Aspose.Diagram 3.6.0. I managed to reproduce these two problems:

DIAGRAMNET-50013 - VSDX to PDF conversion, can’t redirect through a shape hyperlink
DIAGRAMNET-50014 - VSDX to HTML conversion, can’t redirect through a shape hyperlink

This forum thread has also been linked to these issues and you will be notified as soon as these are fixed. We’re sorry for your inconvenience.

Hi Marc,


We have a good news for you is DIAGRAMNET-50014 has now been resolved and its fix will be included in the next version of Aspose.Diagram for .NET 3.7.0. Its release date is not final yet. We will inform you via this forum thread as soon as the new release is published.

The issues you have found earlier (filed as DIAGRAMNET-50014) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hi,

I have tested your fix and the hyperlinks in HTML hasn´t the correct URL.
In the original file the hyperlink looks like: http://roxknowhow/roxtra/Showfolder.aspx?Folderid=1
In the HTML the hyperlink looks like: http://roxknowhow/roxtra/Showfolder.aspx

Hi Marc,


Thank you for sharing your findings. I managed to reproduce the problem. I’ve reopened the issue id DIAGRAMNET-50014 in our issue tracking system. We’ll let you know once a significant progress has been made. We’re sorry for your inconvenience.

The issues you have found earlier (filed as DIAGRAMNET-50013) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hi,

I have tested your fix and Aspose.Diagram for .NET 3.9.0.0 can´t save the file to HTML.
An exceptions was thrown:
“System.ArgumentException: Ungültiger Parameter.\r\n bei System.Drawing.Bitmap…ctor(Int32 width, Int32 height, PixelFormat format)\r\n bei System.Drawing.Bitmap…ctor(Int32 width, Int32 height)\r\n bei ..ƒ–(„˜ page, ImageSaveOptions imageOptions)\r\n bei ..Save(String fileName, HTMLSaveOptions htmlOptions, Diagram diagram)\r\n bei Aspose.Diagram.Diagram.Save(String filename, SaveOptions options)\r\n bei Aspose_Test_Tool.Tools.ConvertVisio(FileInfo p_file, TextBox p_logTextBox, Boolean p_usePdfStandard, String p_PdfStandard) in C:\Users\hofmann\Desktop\Aspose+5\Aspose 5\Aspose-Test-Tool\Aspose-Test-Tool\Tools.cs:Zeile 214.\r\n bei Aspose_Test_Tool.Tools.ConvertFile(DocumentFormat p_format, FileInfo p_file, TextBox p_logTextBox, Boolean p_usePdfStandard, String p_PdfStandard) in C:\Users\hofmann\Desktop\Aspose+5\Aspose 5\Aspose-Test-Tool\Aspose-Test-Tool\Tools.cs:Zeile 52.\r\n bei Aspose_Test_Tool.Main.btnStart_Click(Object sender, EventArgs e) in C:\Users\hofmann
\Desktop\Aspose+5\Aspose 5\Aspose-Test-Tool\Aspose-Test-Tool\Main.cs:Zeile 115.”

Hi Marc,


Thank you for your inquiry. I’m sorry to share with you that I’m not able to notice this error message on my side. Please share the environment details where it fails, i.e. Operating System, .NET Framework, application type (Reports Application etc.). It will be so nice of you if you can attach a sample project which reproduces the issue on your side and attach it here. Also, please share the exact sample code. We’ll investigate the issue at our end and guide you accordingly.

Hi,

thanks for your feedback. Attached I send you an sample project where the issue is reproducable.

My operation system has following configuration:
OS: Windows 7 Professional SP 1
.NET: v4.0.30319
Application type: WinForms-Application
System language: German

Hi Marc,


Thank you for your inquiry. We’re working over your query and will get back to you soon.

Hi Mark,


Thank you for being patient. I’m afraid. I’m still not able to reproduce the error message on my side. I’ve noticed that you are using an old version of Aspose.Diagram 3.7.0 in the provided sample project. Please try using the latest version of Aspose.Diagram 3.9.0 and let us know how it goes on your side. Please refer to the download page:
http://www.aspose.com/community/files/51/.net-components/aspose.diagram-for-.net/default.aspx

In case, It fails with the latest version, then please clarify following details.

Is your PC running the 32-bit or 64-bit version of Windows 7 professional SP 1?
What is the Visual Studio edition or build number?
Which German local system language you have selected? I’ve attached a screenshot.

We’re looking forward to help you.

Hi,

thanks for your help.

The behaviour using the latest version is the same.

My PC has following technical details:
OS: Windows 7 SP 1 32-bit
System language: Deutsch (Deutschland)
Visual Studio: Visual Studio 2010 Version 10.0.40219.1 SP1 Rel
.NET: 4.5.50937 SP1 Rel

Hi Marc,


Thank you for sharing details with us. I’m working to setup another environment and it will take a little time. I shall get back to you in a couple of days.

Hi Marc,

Thank you for being patient. I managed to replicate the said error message at my end. I've logged this issue as follows:

File Name: Visio-Link.vsdx
DIAGRAMNET-50094 - VSDX to HTML conversion, ArgumentException message occurred

Your request has also been linked to this issue. We'll let you know once a significant progress has been made in this regard. We're sorry for your inconvenience.

Hi Marc,

Thank you for being patient. We have a good news for you is that the issue DIAGRAMNET-50094 has been resolved. If there is no issue in the QA phase, then its fix will be included in the next version of Aspose.Diagram 4.0.0. Its release date is not final yet. We will inform you via this forum thread as soon as the new release is published.

The issues you have found earlier (filed as DIAGRAMNET-50094) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

Hi,

the exception appears no longer but the hyperlinks in PDF and HTML are missing.

Hi Marc,


Thanks for reporting us these issues. I’ve re-evaluated your VSDX drawing against the latest build of Aspose.Diagram 4.0.0. I managed to replicate the problem of missing hyperlink. I’ve logged these issues as follows:

File Name: Visio-Link.vsdx
DIAGRAMNET-50103 - VSDX to HTML conversion, hyperlink on a shape is not preserved
DIAGRAMNET-50104 - VSDX to PDF conversion, hyperlink on a shape is not preserved

Your request has also been linked to these issues. We’ll let you know once a significant progress has been made in this regard. We’re sorry for your inconvenience.

Hi Marc,


Thank you being patient. We have a good news for you that the issues DIAGRAMNET-50103 and DIAGRAMNET-50104 have been resolved. If there is no issue in the QA phase, then their fixes will be included in the next version of Aspose.Diagram 4.1.0. Its release date is not final yet. It is expected at the end June 2014. We will inform you via this forum thread as soon as the new release is published.