We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Im getting StatusCode=500 error when attemting to use the ExecuteMailMerge after upgrade to from .NET Core 2.2 to 3.1

Hi,

We are using the Aspose.Words ExecuteMailMerge solution you guys offer for mail merging Word documents for your .NET Core application. It was working well until we upgrade the application from .NET Core 2.2 to 3.1. Now when attempting to use the method with parameters we continue to get the error below. I’ve have also attached the stack trace below.

Error message:
“Error while save file ‘51f6d598-611d-47c7-82c4-8b1097d25496^CoverLetter.docx’ to storage: Windows Azure Storage exception: Invalid Container: null, File path: 51f6d598-611d-47c7-82c4-8b1097d25496^CoverLetter.docx”

Stack trace:
at Aspose.Words.Cloud.Sdk.RequestHandlers.ApiExceptionRequestHandler.ThrowApiException(HttpWebResponse webResponse, Stream resultStream)
at Aspose.Words.Cloud.Sdk.RequestHandlers.ApiExceptionRequestHandler.ProcessResponse(HttpWebResponse response, Stream resultStream)
at Aspose.Words.Cloud.Sdk.ApiInvoker.<>c__DisplayClass12_0.b__0(IRequestHandler p)
at System.Collections.Generic.List1.ForEach(Action1 action)
at Aspose.Words.Cloud.Sdk.ApiInvoker.ReadResponse(WebRequest client, Boolean binaryResponse)
at Aspose.Words.Cloud.Sdk.ApiInvoker.InvokeInternal(String path, String method, Boolean binaryResponse, String body, Dictionary2 headerParams, Dictionary2 formParams, String contentType)
at Aspose.Words.Cloud.Sdk.ApiInvoker.InvokeApi(String path, String method, String body, Dictionary2 headerParams, Dictionary2 formParams, String contentType)
at Aspose.Words.Cloud.Sdk.WordsApi.ExecuteMailMerge(ExecuteMailMergeRequest request)
at NSSAPI.Classes.WaiverManager.CreateCoverLetter(LienWaiver waiver, Guid guid, String financialIntegrationKey) in C:\Users\kalleyne\source\Workspaces\Misc Apps\NSSWFM\Dev\API\NSSAPI\NSSAPI\Classes\WaiverManager.cs:line 141

If you can please assist or point me in the direction of the place to resolve this. I would greatly appreciate it.

Thank you for your time,
Kerwin

This topic has been moved to the related forum: https://forum.aspose.cloud/t/im-getting-statuscode-500-error-when-attemting-to-use-the-executemailmerge-after-upgrade-to-from-net-core-2-2-to-3-1/7908