Free Support Forum - aspose.com

Image character over lap issue while converting wmf to png

Dear support,

We are facing issue against attached wmf image, after converting to png some of character getting over lap.
Please check attached image.zip file over there you will get wmf image and png image.
image.zip (2.3 KB)
Please check this issue as soon as possible.
From
NItin Chopkar

@nitinchopkar,

I have observed the issue shared by you and request you to please try using latest Aspose.Imaging 20.4 on your end. In case there is an issue then please share the used sample code with us.

Ok , I will try with Aspose.imaging 20.4.

Please share us dwnloadable link for Aspose.imaging20.4. Also confirm us its will run with our existing purchased license which we paid at 2017 against Aspose.imaging.

From
Nitin Chopkar

@nitinchopkar,

You need to check that if your license expiry date is after release date of Aspose.Imaging for .NET 20.4, you will be able to use the version.

Dear support,
Thank you for guiding us.
We checked that wmf file into latest version over lap issue resolved but using this version we found that cross sign not recognized , its show square box in place of “Multiply” sign.
Check attached file : wmfsample_issue.png (1.0 KB)
May be this issue related font. can you please help us to resolve this issue.
Our application running under linux operating system. On windows we checked its working. Issue only in linux environment.

From
Nitin Chopkar

Dear support,

Any update on multiple sign not recognizing issue.

From
Nitin Chopkar

@nitinchopkar,

Can you please provide the source file, used sample code and generated output that we will use on our end to log the issue to further investigate it.

Dear mudassir.fayyaz,

I attached zip file which contents what you required. Multiply sign issue.zip (3.8 KB)

Aspose version we used aspose-imaging-18.9-jdk16.jar java.
Running on Linux operating system.
Used in java web application running under tomcat server.

once you extract zip file you will get below :slight_smile:

  1. Source Code : AsposeImageConverter.java
  2. Input wmf file : input_wmfImage.wmf
  3. Out Png file : output_wmfsample_issue.png

Problem : after conversion “X”(Mutiplication sign) appears as sequare box. Not same as input file.
From
Nitin chopkar

@nitinchopkar,

I have observed the issue shared by you and a ticket with ID IMAGINGJAVA-1673 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Ok,
We are waiting for your reply.

Can you tell us intuitively when its will resolve?

From
Nitin Chopkar

@nitinchopkar,

I like to share that the issue has just been created in our issue tracking system and is pending for investigation in issues queue. We request for your patience till the time the issue gets scheduled for investigation and resolution on its due turn. We will apprise you as soon as the issue will be fixed.

Dear support,

Kindly update us a status on our reported issues.

From
Nitin Chopkar

@nitinchopkar,

I have verified from our issue tracking system and like to share that issue has just recently been added in our issue tracking system and is pending for investigation in issues queue. We request for your patience and will share the good news with you as soon as the issue will be fixed.