Image.GetFileFormat() and Image.Load() methods in Aspose.Imaging.dll aren't safe on MTA


#1

Hi Apose team,

We have bought your libraries and implemented it in our software. But we find that find the Image.GetFileFormat() and Image.Load() methods in Aspose.Imaging.dll aren’t safe on MTA.

We have prepared a demo, in this demo, I will get an exception that the file is accessed by another process, bu I’m sure I did’t have another process is accessing the files.
If I use Image.GetFileFormat() or Image.Load() separately, I won’t get the exception(we tried it about 20 times). But if I use them together I will get the exception in a high probability.

And I am not sure if there are any other similar methods also have similar problems.

Would you please have a look?
image.jpg (61.2 KB)

Here are the demo files:

Notes: Please enter your own Aspose license and private key in license.cs file in the demo files. Please try multiple times, since it’s not very easy to reproduce.

Here is the test files:

If you find it’s your library bug, then the other libraries like GroupDocs.Metadata.dll, Aspose.Pdf.dll may also have the same problem. Please also check them. Thanks.


#2

@Glority_Developer,

I have worked with files shared by you and have been able to observe the issue. An issue with ID IMAGINGNET-2688 has been logged into our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved. Also please do not remove files from dropbox so that product team also may download files as well.


#3

OK. Thanks. Please also work with the GroupDocs team, its library also has the similar problem.

Please also look at the other libraries like Aspose.Pdf.dll, etc. Thanks.


#4

@Glority_Developer,

We may only log issues related to Aspose API here in this forums. For Group docs related issues, please log issues in Group docs forums. Secondly, for Aspose.PDF related issue, please log a request in Aspose.PDF forums with all necessary information.


#5

The issues you have found earlier (filed as ) have been fixed in this update. This message was posted using BugNotificationTool from Downloads module by MuzammilKhan


#6

@Glority_Developer,

Can you please use following sample code on your end and share feedback with us if there is still an issue.

using (var image = Image.Load((info as PP).path2))
{
// process image
}