Free Support Forum - aspose.com

Image loading failed: Can not read an image.The structure of the file is unexpected

Hello,
We have problems when we try to open a DXF file with the following code:

using (var dxfFile = (CadImage) Image.Load(dxfFileStream))
{
...
}

You can see the exception in the attached image in this topic.

We’re using Aspose.CAD for NET v20.6.0. We want to get a license for Aspose.CAD, but we need this problem to be solved.

I saw a similiar issue in this thread:

Thanks!

exception.PNG (37.8 KB)

@jguerreroatbertoni,

Please provide the source DXF file that you are trying to load and which is failing so that we may investigate that further to help you out.

Hello @mudassir.fayyaz
I send you the DXF File.

Thanks!

cantopen (304.0 KB)

@jguerreroatbertoni,

A ticket with ID CADNET-1172 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

Hello!
Any news with this issue?

Thanks!

@jguerreroatbertoni,

Can you please try using latest Aspose.CAD for .NET 20.7 on your end as no issue has been observed using that.

image.png (13.7 KB)

Hi, @mudassir.fayyaz

I just updated Aspose.CAD for .NET 20.7. It works!

Thank you very much for your time.

@jguerreroatbertoni

It’s good to know that suggested option worked.