We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Image not rendered in pdf export

Hello,

in the enclosed document instead of the included Image a red cross (as in image missing) is rendered when saving the file as pdf.

This error occurs with Aspose.Words 10.0.1 through 10.4.0.

Best Regards,

Martin Hillert

Hello

Thanks for your request. Actually I do not see this image inside your input document, I see a red cross only. Please try setting full path to this image and make sure that you have access to this image.

Best regards,

You’re right, of course.

I need to brush up my MS Word knowledge. I thought: When after moving the file to another computer the image is still shown, it is surely embedded. Bad luck this time, the image was linked to a network ressource and the server I use to process the file with aspose has no access to the ressource.

Sorry for any inconvenience.

Best regards,

Martin Hillert

Hello Martin,

It is perfect, that you already fond the reason of the problem. Please let me know in case of any issues, I will be glad to help you.

Best regards,

Hello, Andrey,

I found another case where the image rendering failed. Since shape.imageData().isLink() is false I am quite sure this is not a linked image this time… :wink:

I enclose the original document and the pdf created with Aspose.Words v. 10.4.

Best Regards,

Martin Hillert

Hello Martin,

Thank you for reporting this problem to us and for the additional information. I managed to reproduce the problem on my side. Your request has been linked to the appropriate issue. You will be notified as soon as it is fixed.

Best regards,

The issues you have found earlier (filed as WORDSJAVA-422) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.