We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Image not show after convert docx to pdf in linux

Hello
I have a problem when converting docx to pdf the result is that the image does not appear in the pdf file.
for information I do not include a license, does that matter?
i run it on linux ubuntu and include the following script in docker : RUN apt-get update && apt-get install -y libfontconfig1.
i use aspose.words 21.11.0
the following is the docx file and the pdf result:
Nama Customer.docx (26.8 KB)
PrintTest.pdf (31.7 KB)

Thanks

@ahmad.faizin Aspose.Words for .NET Standard uses SkiaSharp to deal with graphics, to make it work on Linux you have to add reference either to SkiaSharp.NativeAssets.Linux or to SkiaSharp.NativeAssets.Linux.NoDependencies

If you add refference to SkiaSharp.NativeAssets.Linux, you should also install libfontconfig1 in your system. SkiaSharp.NativeAssets.Linux depends on this library. You can use the following command to install it:

apt-get update && apt-get install -y libfontconfig1

If you do not have rights to install packages, or other reasons not to install libfontconfig1, you can simply use SkiaSharp.NativeAssets.Linux.NoDependencies, which does not require installation of libfontconfig1.
Also there where few issues reported when using SkiaSharp 2.80.3, if you use this version, please downgrade to 2.80.2 version and let us know if the problem still there.

@alexey.noskov ok thanks your help. just need to downgrqade skiasharp, problem solved

@ahmad.faizin It is perfect that you managed to resolve the problem. I have linked your request to the appropriate issue in our defect database. We will let you know once the problem with SkiaSharp 2.80.3 is resolved.

The issues you have found earlier (filed as WORDSNET-22958) have been fixed in this Aspose.Words for .NET 21.12 update also available on NuGet.