Images are not displaying in PDF


#1

Hello,

I have an issue with images when trying to convert .docx file to .pdf using .NET core on Linux. Images are not displaying in the pdf.

I tried with different formats of images(jpg, png, bmp), but without succeeding.

I am using the latest version of Aspose.Word.

This is the code:

        Document document = new Document("template.docx");          

        using (MemoryStream stream = new MemoryStream())
        {
            document.Save(stream, SaveFormat.Pdf);

            using (var fileStream = File.Create("PDFTemplate-aspose.pdf"))
            {
                stream.Position = 0;
                stream.CopyTo(fileStream);
            }
        }

Any idea what is missing here?
Thanks


#2

@aspusr,

Thanks for your inquiry. Have you tried the latest version of Aspose.Words for .NET i.e. 19.7 on your end? In case the problem still remains, please ZIP and upload your input Word document (you are getting this problem with) and Aspose.Words 19.7 generated PDF file showing the undesired behavior here for testing. We will then investigate the issue on our end and provide you more information.


#3

Yes, we are using the latest version (19.7)
Please find attached the Docx and PDF files.
inputs.zip (79.9 KB)


#4

@aspusr,

We tested the scenario and have managed to reproduce the same problem on our end. For the sake of correction, we have logged this problem in our issue tracking system. The ID of this issue is WORDSNET-18869. We will further look into the details of this problem and will keep you updated on the status of correction. We apologize for your inconvenience.