Free Support Forum - aspose.com

IMPORTANT : from field is sometimes null

Hi,

I have a very huge problem. Since I installed the latest version of aspose.email, some senders of incoming emails are not recognized so the from field is null.

This is VERY problematic as I use Aspose email in my custormer services applications that receive thousands of emails every day.

You will find attached an sample email. Gmail recognize the sender correctly, but not aspose.email. Moreover, for the same email, the previous version of email included in aspose.network did recognize the sender correctly.

Could you please correct this bug very quickly because my csutomers are really angry and don't understand hos a new version can have functionnal regression.

Waiting for your answer...

Hi Jean-Christian,


We are sorry for the inconvenience you are facing.

I was able to observe this issue by using the latest version of Aspose.Email for .NET 2.4.0. However, to log it as a regression issue, I request you to please let us know the version of Aspose.Email that can read the “From” field from the same email message that you have sent to us earlier. We will try to our best to help you as soon as possible.

Hi,

Thank you for your qwick answer. The version that was working was aspose.network v 6.8.0.0

regards,

Hi Jean-Christian,


Thank you for the additional information.

I have forwarded these details to our development team, along with the sample message file, for further investigation and resolution. We will update you here once we have any information and appreciate your cooperation in this regard.

The issue has been logged as NETWORKNET-33575 in our issue tracking system.

Please, correct this bug very very quickly. My customers are french e-mercants leaders and Christmas time is like tomorrow. Then will come the discounts time just at the beginning of next year. Remember the end of the year is the most important period for e-shopping. And my customers will be very angry if they uncounter email problems that could dramatically impact the quality of their customer services during this period. And so wil I.

Regards,

Hi Jean-Christian,


We are sorry for the inconvenience you are facing, and have logged your additional comments against issue id: NETWORKNET-33575 for our development team. However, I would also like to share with you that issues are analysed and fixed on first-come-first-serve basis (except for our PS and ES customers where such issues are prioritized for resolution). In addition, resolution of issues also depend on the complexity of the problem and the duration to fix these may vary.

Anyways, as soon as there is some information in this regard, I will update you here.

Hi Jean-Christian,


We have fixed the issue of null “from” field and have prepared a hotfix for this purpose. Please try it at your end and let us know your feedback.

Thank you for your quick answer.

I will try it as soon as possible and let you know.

Regards,

The issues you have found earlier (filed as NETWORKNET-33575) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.