We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

In textbox in excel file, blank newline appeared in saved file (#99)

Hi,
I have an excel file containing textbox. When I try to get font of some characters from textbox text, new blank row appears in the saved file. In original file there is one blank row between two lines of text, but in saved file there are two blank rows there (should be one). Can you help me with this?

Workbook workbook = new Workbook("2015_Southeastern_Clogging_Convention_Competition_Registration_Form.xls");
Shape shape = workbook.getWorksheets().get(0).getShapes().get(0);
Font font = shape.characters(10, 13).getFont();
workbook.save("2015_Southeastern_Clogging_Convention_Competition_Registration_Form-xxx.xls");

2015_Southeastern_Clogging_Convention_Competition_Registration_Form.zip (60.9 KB)

I used aspose.cells 17.11.0 version for java.

Regards,
Zeljko

@Zeljko,

Thanks for the sample code and template file.

Please try our latest version/fix: Aspose.Cells for Java 18.3. I have have tested using your template file and sample code with v18.3, it works fine and the output file is fine tuned, it does not produce your mentioned issue.

Please also check the document on how to install Aspose.Cells for Java from maven repos. for your reference: https://docs.aspose.com/display/cellsjava/Installation

Let us know if you still find the issue with v18.3.

@Amjad_Sahi,

I tried it with Aspose.Cells for Java 18.3 and issue is still there. I opened it with Excel 2016. Yet, when I open file with Excel 2013, there is no mentioned issue. Have you tried to open it with Excel 2016?

@Zeljko,

Could you open my output file (attached) which is generated using your code segment and template file into MS Excel 2016 and share some screenshots to highlight the issue, we will check it soon.
file1.zip (25.6 KB)

Hi,

Please try it with the attached file (with Excel 2016), I attached wrong file previously.
Please sorry for misunderstanding.

2015_Southeastern_Clogging_Convention_Competition_Registration_Form.zip (15.4 KB)

@Zeljko

Thanks for using Aspose APIs.

We were able to observe this issue as per your description and logged it in our database for investigation and for a fix. Once, the issue is resolved or we have some other news for you, we will update you asap.

This issue has been logged as

  • CELLSJAVA-42570 - Blank new line appears inside the textbox after processing and saving the Excel file

Screenshot:

@Zeljko,

This is to inform you that we have fixed your issue “CELLSJAVA-42570” now. We will soon provide the fix after performing QA and including other enhancements and fixes.

@Zeljko

Thanks for using Aspose APIs.

Please download and try the following fix and let us know your feedback.

The issues you have found earlier (filed as CELLSJAVA-42570) have been fixed in this update. This message was posted using BugNotificationTool from <a href=“https://#{request.env[“HTTPS_HOST”]}”>Downloads module by Amjad_Sahi

The issues you have found earlier (filed as CELLSJAVA-42570) have been fixed in Aspose.Cells for Java 18.4. Please also see the document for your reference:
https://docs.aspose.com/display/cellsjava/Installation