Free Support Forum - aspose.com

Inconsistent end of line in acwmain.js

Hi,

I use the gridweb control for ASP.NET application and since I have got the latest version of the control (2.7.14.2000) I have some issue with the acwmain.js file. First, when I try to open it, Visual Studio displays an alert which says that ‘the end of line of the file are inconsistent’ and if I want to change it to Windows (CR LF).

The issue is whatever I do with that end of line, the gridweb don’t work because of Javascript.

I just want to know you had the possibility to give me a well formatted acwmain file.

Thank you.
Best regards,
Romain.

Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

We will evaluate your requirements and provide you such a file if possible. I think, acwmain file is in such a condition because of code security.

We have logged this issue in our database. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41322.

Hi,


Please try the Aspose Cells GrideWeb v2.7.14.2003.


Here is the latest (Aspose.Cells.GridWeb.2.7.14.2003) source .js file (attached) for your needs.


Thank you.

Hi,

Thank you for your answer,

However, I still have a Javascript issue. In fact, when I load a workbook with the latest version of the GridWeb Control, it spends about 30sec.

To illustrate the problem, I’ve attached you two sample projects. In fact, that is the same project but one of them uses the 2.7.10.2001 version of the GridWeb and the other one includes the latest version (2.7.14.2003). You just have to execute the projects and click on the top right button “Click here”. You will see a big load time difference. I thought it was because of the inconsistent end of line in acwmain.js but now I think that the problem is elsewhere. To help you to identify it, I have put some timers and logs in the acwmain file included in the latest version project.

I just want to point that I use IE9 browser to execute the projects.

I hope you will help,
Thank you,
Romain

Hi Romain,


Thanks for sharing two separate projects.

Please spare us some time as we need to evaluate your issue. We will look into your issue and get back to you soon.

Thank you.

Hi,


Sorry for a bit delay.

I have logged a ticket with an id “CELLSNET-41359” for your issue. We will look into it soon to figure it out.

Once we have any update on it, we will let you know here.

Thank you.

Hi,

Thank you for your reply,

I’m waiting for an update as soon as possible it’s very hard for me to deal with that slowness,

Thanks,
Romain.

Hi,


I have checked your ticket (logged for your issue into our internal database), it is “In Process” at the moment. Our concerned developer is working over your issue, once we have any update on it, we will let you know here.

We are sorry for any inconvenience caused!
Hi,

We have added a new option variable needInitAligmentAdjust in the .js script file for your needs.
The default value is true. If it is true, GridWeb will render cells in vertical alignment on page's load event. It will set span height based on offsetHeight for every span, if the cells number is huge, it will cost lots of time. So, if you do not care of vertical alignment of the content inside one cell, we can set needInitAligmentAdjust to be false, so that Gridweb will not do the vertical alignment for cell content on the page's load. However, we have been using async call to do this adjustments, and now even we enable it, the user experience would be still good.

We will release the next version v7.2.15.2000 tomorrow in the new official release of Aspose.Cells for .NET v7.4.0. We will also provide you the updated .js file that you may use.

Thank you.

Hi,


Please try our latest version v2.7.15.2000 (GridWeb), you may download and install our next official version of Aspose.Cells for .NET and get the latest version:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry439948.aspx

Please find attached the latest updated .js file(s) from the archive or replace the complete “acw_client” folder with the attached one (after extracting the attached archive).

Thank you.