We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Incorrect Spreadsheet ML is created when CurrentCulture is set to something other than English

The following code produces the attached xml file.

var cultureInfo = new System.Globalization.CultureInfo(“fr-FR”);
System.Threading.Thread.CurrentThread.CurrentCulture = cultureInfo;
System.Threading.Thread.CurrentThread.CurrentUICulture = cultureInfo;

var worksheet = new Workbook().Worksheets[0];
worksheet.Cells[0,0].PutValue(100.50);
worksheet.Workbook.Save(“french.xml”, FileFormatType.SpreadsheetML);

Below is a portion of the XML. If you notice, the DefaultRowHeight attribute has a value of 12,75. The value really should be 12.75. It looks like the decimal value format for the current culture is used (comma (,) instead of period (.)) when setting the value. This is incorrect. Everything in the xml file should use the default decimal value of period.


<ss:Names />
<ss:Table ss:DefaultRowHeight=“12,75” ss:DefaultColumnWidth=“48” ss:ExpandedRowCount=“1” ss:ExpandedColumnCount=“1”>
<ss:Row ss:Index=“1”>
ss:Cell<ss:Data ss:Type=“Number”>100,5</ss:Data>
</ss:Cell>
</ss:Row>
</ss:Table>


I have confirmed this by saving a Spreadsheet ML file directly from a french version of Excel with my regional settings set to French. Every number in the file that has a decimal uses a period (.) instead of a comma (,).

Is it possible to get this fixed?

Thanks

Harry

Hi Harry,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for considering Aspose.

We have found your mentioned issue after an initial test. We will look into it and get back to you soon. Your issue has been registered in our internal issue tracking system with issue id CELLSNET-14139.

Thank you & Best Regards,

Hi,

We have fixed your mentioned issue, kindly try the attached version.

Thank you.

The fix appears to be working.

Thank you for your quick turn around

Harry

The issues you have found earlier (filed as 14139) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.