Free Support Forum - aspose.com

Install Aspose.Words SharePoint License Package (.wsp) on SharePoint 2016 - stsadm.exe addsolution deploysolution

We have installed the license wsp in the farm, but we still get the evaluation watermark in the generated PDF:s. The license is a Developer OEM bought a few years ago. The license file is located at C:\Program Files\Common Files\microsoft shared\Web Server Extensions\16\TEMPLATE\FEATURES\Aspose.Words.SharePoint\Aspose.Words.SharePoint.lic and C:\Program Files\Common Files\microsoft shared\Web Server Extensions\14\TEMPLATE\FEATURES\Aspose.Words.SharePoint\Aspose.Words.SharePoint.lic
on a SharePoint 2016 on-prem server. The only Aspose package installed is the license package. Why are we getting watermarks?

@stretchdp,

Please send your SharePoint license package file (.wsp) via private message. In order to send a private message with attachment, please click on my name and find “Message” button:

Fix System.InvalidOperationException Error upon Setting Aspose.Words License

We will then investigate the issue with your license file on our end and provide you more information.

P.S. Please do not share your license file publicly in forum threads.

I did send it. Please advise on how to proceed.

@stretchdp,

Thank you for sharing license file via private message. We will check it on our end and update you with our findings soon.

@stretchdp,

We have installed the latest version of Aspose.Words for SharePoint i.e. 19.8 on our end. Then we deployed the WSP license solution that you shared via Private Message. After that when we perform DOCX to PDF conversion for example, we see the following error message (note: the conversion still finishes but there will be an evaluation message in generated PDF because the license being used is expired).

Install Aspose.Words SharePoint License Package (.wsp) on SharePoint 2016 - stsadm.exe addsolution deploysolution

So, please make sure that you are using the correct license or you need to upgrade your license subscription to be able to use the latest version of Aspose.Words for SharePoint. For renewing/upgrading a license subscription, please contact our sales team via Aspose.Purchase forum or visit https://company.aspose.com/contact.

I dont want to use the latest version, I want to use the version we have installed, which is older? Can’t I do that?

@stretchdp,

The license you shared should work fine when you use old Aspose.Words for SharePoint 18.6 as it was released/published on 27th Jun 2018 and your license expired on 28th Jun 2018. Hope, this helps.