Free Support Forum - aspose.com

Installing via NuGet the Aspose.Total for .NET Complete Package containing all .NET File Format APIs offered by Aspose

When I try to install from Nuget I get this:

PM> Install-Package Aspose.Total -Version 21.1.0
Attempting to resolve dependency ‘Aspose.Words (≥ 21.1.0)’.
Attempting to resolve dependency ‘Aspose.Cells (≥ 21.1.0)’.
Attempting to resolve dependency ‘Aspose.PDF (≥ 21.1.0)’.
Install-Package : ‘Aspose.PDF’ already has a dependency defined for ‘System.Security.Permissions’.
At line:1 char:1

  • Install-Package Aspose.Total -Version 21.1.0
  •   + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
      + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
    
    

PM>

Also, “dotnet add package Aspose.Total --version 21.1.0” doesn’t work in the CLI because I don’t have .Net Core SDK.

Can’t I just download the DLL’s? Can’t find them online. That’s how I ended up with 20.11. It was what was available as DLL download.

@rdaviessci

Please download the sample project from this download link. There is no issue in configuring from latest Nuget package 21.1. Can you please try the shared one or clear all packages from your solution and try again.

Here are screenshots of the NuGet (non-Package Manager Console) failure, and the references currently in the VB project.NuGetFailure References.zip (48.0 KB)

Also, when I try to open TestAsposeTotal.sln I get:

C:\Aspose\Archive\TestAsposeTotal\TestAsposeTotal.csproj : error : The default XML namespace of the project must be the MSBuild XML namespace. If the project is authored in the MSBuild 2003 format, please add xmlns=“http://schemas.microsoft.com/developer/msbuild/2003” to the element. If the project has been authored in the old 1.0 or 1.2 format, please convert it to MSBuild 2003 format. C:\Aspose\Archive\TestAsposeTotal\TestAsposeTotal.csproj

@rdaviessci

Can you please share the sample visual studio project that is failing on your end. The one that is successfully loading Nuget package on our end has underlying .NET Core 3.1 application. It may be that particular API assembly that are resolved via Nuget based on application framework has issue. But we will be able to investigate this on provision of requested information.

Here is the link to a VPTFileProcess.zip on dropbox -

@rdaviessci

We have verified the sample project shared by you and that too loaded all Nuget packages without any issue on our end. No dependencies error occurred during Nuget restore and please check this image for your convenience as well. The issue likely related to an older version of NuGet Package Manager on your end and there are many discussions over the internet about it. One such example can be found over this link. The The problematic assembly requires NPM version 2.12 or higher. Please consider updating that on your end. I hope this will resolve your issue as we have tried this on multiple machines and multiple Visual Studio environments with your sample project even but non reproducing the issue.

I installed the NuGet for Visual Studio 2013 found at -

NuGet Package Manager for Visual Studio 2013 - Visual Studio Marketplace

And I got farther with the NuGet installation than I had before…
But I still get the errors that I pasted into the attached zipped Word docx.
Aspose.Total 21.1 Install Fail.zip (52.4 KB)
Thank you for your help!

Question: do I have to install Aspose.Total 21.1? Can I just install Aspose.Words 21.1 (and Aspose.Words.Pdf2Word)?
The version of Aspose.Cells I have is working fine, and I don’t need the rest of Total right now.

@rdaviessci

It depends on your requirements how you can proceed to fulfil them. From our side, we have already share the detailed analysis and possible solution with you.

Ok, yes, I was able to individually install Words and the newer Cells from NuGet. Thank you, and Monday I’ll start retesting those problematic PDFs that 20.11 couldn’t handle.

@rdaviessci

That’s great. I hope you will be able to coup up with situation based on suggested measures require to be taken.