We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Integrate with Microsoft Report Viewer in Local Mode

I downloaded the eval and am trying to get the demo to work, but running into a few problems. I’m using VS 2005 and have included the sample code/references to my project, but cannot get it to compile. I confirmed the dll version is correct, install from the msi went fine.

In the code: AddExtension(reportViewer1, “AWDOC”, “DOC - Word Document via Aspose.Words”, GetType(Aspose.Words.ReportingServices.DocRenderer))

I get the following error: Reference required to assembly Micrsoft.ReportingServices.ProcessingCore, Version=9.0.242.0

I tried to add a reference to this, but when I do I get an error in the AddExtension sub about the IRenderingExtension being ambiguous.

Hi Craig,

Thanks for your query. I have tried to understand your problem statement but unfortunately I have not completely understand your problem statement. Please share some more information about your issue and it would be great, If you share your sample project along with RDL file for investigation purposes.

Here is the project. Basically, I just created a new project, added a reportviewer control and copied your code from the help section and added the references. It should compile, but it does not.

Have you looked at the sample project?

Hi Craig,

Thanks for sharing the code. I am working on shared issue and will update you soon.

Hi Craig,

Please add following DLL references in your project.

Microsoft.ReportingServices.Interfaces


Microsoft.ReportingServices.ProcessingCore.dll



You can find these DLL at following location.

::\Program Files\Microsoft SQL Server\MSSQL.\Reporting Services\ReportServer\bin

Hope this helps you. Let us know, If you have any more queries.

I added the references as you suggested, but now get the following error on this line: Dim commonAssembly As System.Reflection.Assembly = GetType(IRenderingExtension).Assembly

IRenderingExtension is ambiguous in the namespace Microsoft.ReportingServices.ReportRedering

Hi,


It seems like there were invalid references in the Aspose.Words for Reporting Services assemblies that are used for integration with Report Viewer. This is a known issue and we are preparing 3.5.1 hotfix right now. It will be released later today. BTW, it will include noticeable performance improvements. Sorry for inconvenience.

Tahir or whoever is responsible, please link this issue (and others that look similar) to WORDSRPT-102.

Thanks.

Any update on the hot fix?

Hi


Thanks for your request. Unfortunately, the issue is not resolved yet. But it will be fixed before the next release. We will let you know once it is fixed.

Best regards,

So I should uninstall and demo the 3.4 version?

Hi Craig,

Please see my reply here. Did this workaround not resolved your issue?

The issues you have found earlier (filed as WORDSRPT-102) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)