We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Is there a way to deal with long mail merge field names? Potential bug?

I found this old forum post (BUG: Long mail merge fields - values not appearing in output) which describes my issue pretty well, but don’t see a solution.

Basically, our application allows users to define their own mail merge field names, but when these names exceed 40+ characters they appear as truncated in Microsoft Word. For example, if the mail merge field name was “Customer_Order_Detail_Product_Option_Name”, which is 42 characters long, when attempting to select it from the mail merge menu in Word, it would appear as “Customer_Order_Detail_Product_Option_Nam” (notice the last character “e” was removed).

Also, if we had multiple fields with the same 40+ character prefix like:

“Customer_Order_Detail_Product_Option_Price_Retail” (50 chars)
“Customer_Order_Detail_Product_Option_Price_Sale” (48 chars)
“Customer_Order_Detail_Product_Option_Price_Discount” (52 chars)

Word would display these as:

“Customer_Order_Detail_Product_Option_Pri”
“Customer_Order_Detail_Product_Option_Pr1”
“Customer_Order_Detail_Product_Option_Pr2”

And the person trying to work with the template wouldn’t know what the “Pri”, “Pr1”, and “Pr2” suffixes are referring to.

As bad as that is, I can sort of live with it (since that’s just the way Word works what choice do I have)…but the real problem is that when we programmatically run the mail merge process, our data fails to map to the truncated name and the merge field is NOT replaced. This is because we’re mapping our data to the non-truncated merge field name.

Is there any solution to this besides forcing our users to not exceed 40+ characters (which is extremely limiting)?

Hi Dan,

Thanks for your inquiry. You may try MappedDataField property to map fields in the template and data source. You can get list of fields in the template and list of columns in your data source and then map corresponding fields with the corresponding columns in your data source. Please check following documentation link. Hopefully it will help you to resolve the issue.

Using Mapped Field(Mail Merge).

Best Regards,

Hi Tilal,

Thanks for the response. That looks like it may work, but is there anyway to automatically do this for when Word auto-truncates the existing merge field names? Otherwise I’ll have to sort of reverse-engineer the algorithm Word uses to truncate the names and then map my data source’s field names to those reverse-engineered names.

Also, I’m assuming there’s no way to prevent Word from truncating the merge field names in the first place, correct? That would obviously be the best solution, but I’m guessing that’s just the way Word does things and we can’t change it, correct?

Thanks,
Dan

@dhartley

Thanks for your feedback. I am afraid there is no other option available for auto-truncated (long mailmerge fields) available in Aspose.Words.

As per my knowledge, your assumption is correct about MS Word. There is no way to prevent long mailmerge field names truncation in MS Word. As a suggestion, you may avoid using such long field names and use short descriptive columns names without white spaces.

We are sorry for the inconvenience.

Best Regards,