We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issue at assembly reference

Hi,

I am trying to test example provided in the following link.

Example

In a windows application I have tried to add reference of Aspose.Pdf (downloaded from following link Aspose.Pdf for .NET7.5.0(dlls only) and it got added then I tried to add reference of Aspose.BarCode for .NET5.2.0 (dlls only) then tried to compile the application, it is throwing error like "The type or namespace name 'Pdf' does not exist in the namespace 'Aspose' (are you missing an assembly reference?" even though reference exists.



Hi Sreenivas,


Thank you for your interest in our Aspose products.

It’s because the dll is targeting a different framework than what was specified in the project. Can you please try adding the reference like this?

1. Right Click on Bin folder and select Add Reference

2. Browse to the folder containing Aspose.BarCode 5.2.0 dlls

3. Select appropriate .net folder (.net framework should be same as you have specified in the project)

4. Select the dll and click OK

If you still find some problem then please share details. We’ll further investigate the issue.