Free Support Forum - aspose.com

Issue installing Aspose.Words on Windows 2008R2 w/ SQL 2008 Enterprise Edition

Hello.

I've downloaded a demo of Aspose.Word for SSRS -- it seems like exactly what I need for rendering to TXT and HTML so my Blackberry users can read their reports. My AMEX card is sitting on the table next to me, eagerly waiting to spring into action for an online order of this product. This issue is the only thing standing in the way of my card's gratification. Please help.

The product installs perfectly on my desktop (Windows XP SP2, SQL 2k8 Enterprise) and renders beautifully on a variety of reports.

When I install on my Windows 2k8 R2 (64-bit, obviously) w/ SQL 2k8 Enterprise, things don't go so smoothly.

The error I get during installation is: "Could not properly install or configure Aspose.Words for Reporting Services on this machine. Please try installing Aspose.Words for Reporting Services manually as described in the documentation".

So ... I listened, and tried a manual installation. Given that I didn't have the constituents of the .MSI, I pulled the DLLs off of my PC (which has a good installation). I updated both the RSReportServer.config and RSSrvPolicy.config files by hand and bounced the server just to be sure it all took. The renderers show up in SSRS, and work on occassion, but when I have any report with hierarchical tables (seems to be the common theme), I get this rendering error:

An error occurred while exporting the report.
error message Could not find any recognizable digits.
stack trace " at System.ParseNumbers.StringToInt(String s, Int32 radix, Int32 flags, Int32* currPos)
at System.Convert.ToInt32(String value, Int32 fromBase)
at Aspose.Cells.ReportingServices.Utils.xc5e7b7dc64f3f7a6.x00872a2743ed58d0(String xf50d6d3c10c0eac9)
at Aspose.Cells.ReportingServices.ReportItem.x77f91d2130d08599.x3f88a25febd23896()
at Aspose.Cells.ReportingServices.ReportItem.x77f91d2130d08599.GetFormatDefine()
at Aspose.Cells.ReportingServices.ReportItem.x4baaeff2346b420f.x6afdbeb67b972fb3(ReportItem xccb63ca5f63dc470, Int32 x72d92bd1aff02e37, Int32 xe360b1885d8d4a41)
at Aspose.Cells.ReportingServices.ReportItem.x4baaeff2346b420f.x2c44f534085b543c(TablixMember x25f90284444cb6d5, x693f8d3047025a5e xa806b754814b9ae0, Int32 xa447fc54e41dfe06, Int32 xc941868c59399d3e, Boolean& x8fc2d66566293701)
at Aspose.Cells.ReportingServices.ReportItem.x4baaeff2346b420f.xacf56269b403df30(x693f8d3047025a5e xa806b754814b9ae0, Int32 xa447fc54e41dfe06, Int32 xc941868c59399d3e)
at Aspose.Cells.Reporti"
This file is created with Aspose.Cells for evaluation only with an Evaluation License.
It is strictly prohibited from using it in the production of any software.
Any violation of this provision shall require a mandatory purchase of pay license
as well as expose the user to other legal recourse for collection and punitive damages.
Copyright 2003 - 2010 Aspose Pty Ltd.

I can provide more log info (System Event, SSRS logs, ...) but wanted to understand if this should work on my configuration before I bang my head any further.

Thanks,

Brian

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for reporting this problem to us. Your request has been logged in our defect database. The developer, who is responsible for Aspose.Words for Reporting Services will answer you shortly.

Best regards.

Hi, Alexey. I haven't been contacted on this -- do you know if it's being actively worked on ? I'm still interested in the product, pending a solution to the Windows 2008 installation issue.

Regards,

Brian

Hi Brian,

Sorry for that, I am looking into your issue right at the moment. Please expect a response shortly.

Thanks.

Just one quick note, please comment. The installation error is known and that’s what I’m going to work on and fix, but the second error you encountered (after you installed the product manually) is obviously caused by Aspose.Cells for Reporting Services, rather than by Aspose.Words, judging by the stack trace.

Guilty as charged -- when I couldn't get Aspose.Cells to work, I tried Aspose.Words. Both exhibited the same behavior, however.

Please let me know if there's anything I can do to help you debug the issue in my 2008 dev environment.

Hi, Dmitry – any progress on this ? Thx.

Hi,

Sorry for a delayed response again - I was on a 5 days vacation with my colleagues. However, I managed to test installation of the product on a few virtual machines with different OSes installed and there were no problems. So that's what I decided to do. I have built a MSI installer that does not suppress the exact exception with a common message. Please unzip and try it, then when installation fails, you should see the actual error message. Let me know it then, I hope it will shed some light on what's going on.

You could also provide some MSI logs but I'm not sure it will be helpful because the installation fails during custom actions stage (when the dlls are being copied).

Thanks.

I've attached a screenshot of the error message from the new installer.

System.ArgumentNullException: Value cannot be null.

Parameter name: path1

Thanks. Obviously the issue has to do with determining RS instance paths. We determine them from the registry, so could you please check the following registry entries:

HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\Instance Names\RS - should contain Reporting Services instance names,

HKLM\SOFTWARE\Microsoft\Microsoft SQL Server\\Setup - should contain SQLPath key whose value is the actual path to the instance.

If everything is okay there, then probably we may end up sending you the installer project to detect the actual crash point.

Thanks for you help.

At a quick glance, the registry entries seem reasonable. Screenshots are attached.

Okay. Now I have to sorry for further bothering you, but:

1) Please try another version of the installer (I changed WOW64 options for reading registry entries there, that's what I suspect may be the cause).

2) Do you have any versions of Visual Studio installed on the virtual machine?

Sorry for the late response... screenshot of the new error is attached.

I also see a few entries in the system and application event logs. Most descriptive is this:

The description for Event ID 11001 from source MsiInstaller cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

If the event originated on another computer, the display information had to be saved with the event.

The following information was included with the event:

Product: Aspose.Words for Reporting Services -- Error 1001.

(NULL)

(NULL)

(NULL)

(NULL)

(NULL)

the message resource is present but the message is not found in the string/message table

Good morning. Next steps ? Thx.