Issue when grouping pivot table by date and saving as PDF


#1

Hi,
I am having an issue with Aspose Cells version 18.6.0 (Latest version 19.8 has the same issue).
I have this pivot table that groups by date column (per Month), the months I have are August and September but my PDF shows the incorrect months, PDF shows April and Jun and rows are not in the correct order either, no idea why it displays April and Jun, my data source does not have those months.

Please see the attached project with a sample app in order to duplicate issue.
Follow these easy steps:

  1. Unzip and run the attached project.
  2. Notice I included a sample excel file that was also generated by AsposeCells at some point in my application. The name of the sample file I attach in the same zip file is “SampleFile.xlsx”
  3. From the app, select this excel file, it gets converted to PDF, open the excel file and compare it with the generated PDF, they do not match at all. I call a bunch of “refresh” methods (you can see in the code) but the issue still there, generated pdf is different from the original excel file.

Is there a workaround for this issue? or am I missing something?
Sample Project.zip (322.0 KB)

Thanks!


#2

@sumiflow,
We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46882 - Issue when grouping pivot table by date and saving as PDF


#3

Got it! I will keep an eye on this issue.
Thank you so much for the prompt response.


#4

@sumiflow,

The file named “SampleFile.xlsx” doesn’t contain the data in the worksheet named “Heavy Load Data”. In order to solve the issue we need it. Could you also provide the sample file with data to evaluate/figure out the issue soon?