Free Support Forum - aspose.com

Issue while converting Doc to HTML- unknown characters appear

Hi,
We are using Aspose jar V16.4.0 with CentOS 7.4 and facing issue while converting DOC to HTML. If converted on CentOS 6.9 or below, it is working fine.

Please help as i want it to work on Centos 7.4

Issue while converting Doc to HTML- unknown characters appear

@naveenpotter,

Thanks for your inquiry. To ensure a timely and accurate response, please attach the following resources here for testing:

  • Your input Word document.
  • Please attach the output HTML file that shows the undesired behavior.
  • Please attach the expected output HTML file that shows the desired behavior.
  • Please create a simple Java application (source code without compilation errors) that helps us to reproduce your problem on our end and attach it here for testing.

As soon as you get these pieces of information ready, we’ll start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.

aspose.zip (26.9 KB)
Please find the details u asked for.

@naveenpotter,

Thanks for sharing the detail. The shared converter.java is not Java file. We have converted the shared DOCX to HTML using latest version of Aspose.Words for Java 18.5 and have not found the shared issue. Please use Aspose.Words for Java 18.5.

If you still face problem, please share the simple Java application that helps us to reproduce your problem on our end. Thanks for your cooperation.