We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issue with Aspose Chart "Interval between labels"

We are upgrading our Aspose Cells from 8.7.1 to 18.6.0. One of report with chart change the interval between label to 1. In version 8.7.1, that was by default Automatic. Please let us know how to set it as Automatic in version 18.6.0
Attaching sample application and Image of the issue.

AsposeChartIssue.png (63.9 KB)
SampleApplication.zip (3.8 MB)

Please let me know the fix for that.

@kumarabhishek06,

Thanks for the sample project with template file and screenshot.

I tested your scenario/ case using your sample project with template file using v8.7.1 and it works fine the same way as v18.7.x. Please find attached the output file (by v8.7.1) and see the screenshot for your reference:

file1.zip (14.1 KB)

Can you please tell me how to set Interval between labels “Automatic”?

@kumarabhishek06,

Could you provide details which version was setting “Interval between labels” to “Automatic” (when using your original code from your sample project), we need to check if the behavior was changed in the newer versions.

Aspose Cells 8.7.1 was setting interval Automatic.

@kumarabhishek06,

That is strange as I did test your scenario/case with your sample project (with template file) using v8.7.1 and it was not setting “Interval between labels” option to “Automatic”, see my previous reply with attachment and screenshot for your reference:

This is behaving differently in our environment. Is there any way, we can set it Automatic with new version?

@kumarabhishek06,

I am not sure if we can set your desired option automatic via APIs (it is set internally based on the specified data for value axis and category axis), we will check it further though. By the way could you open my attached file in your MS Excel manually and check if you could see any difference. Also, I am using MS Excel 2007.

Also, you may print the Aspose.Cells version on console or in message box for confirmation, see the document for your reference:
https://docs.aspose.com/display/cellsnet/Check+Version+Number

Moreover attach your output file by Aspose.Cells for .NET v8.7.1.

@kumarabhishek06,

We have evaluated your issue/requirements further.
We found the value of the source file “AP_MG_EMDLC_EXPOSURE_BYPART.xlsx” is not automatic, so the exporting file is not automatic regarding label intervals. I have logged a ticket with an id “CELLSNET-46281” for your issue. We will provide “IsAutoTickLabelSpacing” property for axis in the new fix.

Once the fix is available for public use, we will share the Download link here.

@kumarabhishek06,

Please try our latest version/fix: Aspose.Cells for .NET v18.8

Your issue should be fixed in it.

Let us know your feedback.