Issue with redacting a generated PDF using Adobe

I can generate a PDF from an email message or a XLSX (using PdfFormat.v_1_7 format), when I edit that PDF in Acrobat I can redact the information and everything is fine.
If however that same PDF was generated as PdfFormat.PDF_A_3A I get the following error when I try to apply the redaction in Acrobat.
“Wrong type parameter supplied to PDS procedure”

If I try and convert the 3A file to a different format I still get the error, I’ve also tried the same with the RemovePdfaCompliance method and adding a page but still no luck.

So far the only way I can get redact to work is generate originally as v_1_7 or manually print the PDF using Microsoft Print to PDF.

I’m using C# and the latest versions of the nuget packages


To ensure a timely and accurate response, please attach the following resources here for testing:

  • Please share the APIs that you are using.
  • Your input PDF.
  • Please attach the output PDF file that shows the undesired behavior.
  • Please create a sample application (source code without compilation errors) and attach it here for testing.
  • Please share all steps to reproduce the same issue at our end.

As soon as you get these pieces of information ready, we will start investigation into your issue and provide you more information. Thanks for your cooperation.

PS: To attach these resources, please zip and upload them.