We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issues with extracting quite complex charts

I've prepared a set of extracted charts by both JAVA and .NET Aspose Cells components.
As instructed, I used the latest version of both - 8.0.1.4
These are examples of quite complex charts, that don't get extracted properly.
Find in the package the source spreadsheet, extracted charts in *.emf format, and comparision images (*.png) showing found issues in corresponding charts.

There are a few issues, some of them are repeating:
- unequal allignment of axis values
- legend mark is not thick enough
- textboxes are placed wrongly, some overlap each other
- missing axis values
- different orientation of the legend
- unwanted space between axis values and the bound of chart
- wrong axis values


Hi Tomasz,


Thank you for providing your detailed analysis and sample spreadsheet for our evaluation.

We are able to replicate most of the problem while rendering charts to EMF format, and have logged appropriate tickets for further investigation & correction purposes. Please find below the details for your kind reference.

  • CELLSNET-42636: Missing Axis Values
  • CELLSNET-42637: Missing Axis Title
  • CELLSNET-42638: Legend Marks have Different Thickness
  • CELLSNET-42639: Text Boxes have been Misplaced
  • CELLSNET-42640: Orientation of Legend has Changed
  • CELLSNET-42641: Wrong Axis Values

Please guide us regarding the following issues, so we could replicate the problem and move forward to report them.

  • Unequal alignment of axis values
  • Unwanted space between axis values and the bound of chart

Moreover, all the tickets referenced above are for the .NET version of the Aspose.Cells API, and the same has been attached to this thread for automatic notifications. If you are interested in the Aspose.Cells for Java as well then we will attach equivalent tickets for the Java version of product to this thread. Please note, in that case you will receive double notification for each issue when a fix is publicly available.

Thanks,


Yes we are also interested in the Aspose.Cells for Java component, as we are currently evaluating both .NET and JAVA platforms, so please attach tickets for JAVA as well.

Regarding issues:
  • Unequal alignment of axis values
  • Unwanted space between axis values and the bound of chart
The first issue is visible in files
“chart_graphs_0_net_issues.png”
“chart_graphs_3_net_issues.png”
“chart_graphs_3_java_issues.png” (this one is most affected)
Labels of the date axis aren’t alligned to the top - one label reaches higher than others etc.
I’ve marked that with red rectangle so that you can see different distance between the characters and rectangle’s edge

Second issue appeared in JAVA examples
"chart_graphs_1_java_issues.png"
"chart_graphs_2_java_issues.png"
there is some additional space between the axis labels and the chart - I’ve marked the space with red rectangle in these examples

Hi Tomasz,


Please find below the consolidated report of your identified problems while rendering the Excel charts to EMF format with Aspose.Cells for .NET & Java.

Problem

.NET Ticket

Java Ticket

Missing Axis Values

CELLSNET-42636

CELLSJAVA-40818

Missing Axis Title

CELLSNET-42637

Didn't Reproduce

Legend Marks have Different Thickness

CELLSNET-42638

Didn't Reproduce

Text Boxes have been Misplaced

CELLSNET-42639

Didn't Reproduce

Orientation of Legend has Changed

CELLSNET-42640

Didn't Reproduce

Wrong Axis Values

CELLSNET-42641

CELLSJAVA-40819

Unequal Alignment of Axis Values

CELLSNET-42643

CELLSJAVA-40820

Text Box is Missing

CELLSNET-42644

CELLSJAVA-40821


As you may see from the above provided details that a few problems didn't replicate with Aspose.Cells for Java, this could be due to the reason that we have evaluated the mentioned problems against the latest build of Aspose.Cells for Java 8.0.2. Moreover, the issue related to the "unwanted space between axis values and the bound of chart" is due to the reason that the referenced charts have text boxes that didn't get rendered in the EMF, so its seems that there is extra space between axis values and chart bounds. We have logged this problem for both platforms under ticket Ids CELLSNET-42644 & CELLSJAVA-40821.

Please spare us little time to properly analyze the problem cause, and to provide fix for all the mentioned issues. In the meanwhile, we will keep you posted with updates in this regard.


PS: All tickets have been attached to this thread for automatic notifications.

Hi,

Is there any update to these issues ?

Hi Tomasz,


Thank you for your patience with us.

Unfortunately, the tickets attached to this thread are not resolved yet. We have elevated the priority of all the tickets, and recorded the notes for the concerned development team member to share the estimated release scheduled for the fix. As soon as we receive more updates, we will post here for your kind reference.

Please accept our sincere apologies for the inconvenience caused to you.

The issues you have found earlier (filed as CELLSJAVA-40821;CELLSJAVA-40819;CELLSJAVA-40818) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.
Thanks for the update.
We've tested the fixed issues and all seems to work, except for issue CELLSJAVA-40821 "Text Box is Missing".
For chart 9 in sheet "Graphs" the textbox appears as expected, however for chart 13 the textbox is still missing. We tested it on the same excel as in the archive attached to my first post in this thread.

Hi Tomasz,


We are sorry for the inconvenience caused to you.

We have tested the scenario while using the latest version of Aspose.Cells for Java 8.2.1 against the Chart 13, and was able to replicate the problem of missing text box on the chart surface. The ticket logged earlier as CELLSJAVA-40821 has been re-opened providing the additional information. As soon as we receive more updates in this regard, we will post here for your kind reference.

Hi Tomasz,


Thanks for using Aspose.Cells.

We have looked into this issue further. The Textbox “Operating Rate, %“ does not belong to Chart 13. If you drag Chart 13 in Excel, the Textbox does not move with the chart. So it does not display in Chart2Image image.

Thanks for the reply. Indeed, the issue in the case is not fault of Aspose.Cells but unproperly created chart in excel.


Hi Tomasz,


Thanks for your posting and using Aspose.Cells.

It is good to know that you now know the root cause of this issue, you will be able to fix your chart now. Let us know if you encounter any other issue, we will be glad to look into it and help you further.

Hi,


Please try our latest version/fix: Aspose.Cells for .NET 8.2.1.2
We have fixed the following issues:

  • CELLSNET-42636: Missing Axis Values
  • CELLSNET-42637: Missing Axis Title
  • CELLSNET-42638: Legend Marks have Different Thickness
  • CELLSNET-42639: Text Boxes have been Misplaced
  • CELLSNET-42641: Wrong Axis Values
  • CELLSNET-42644
Let us know your feedback.

Thank you.

The issues you have found earlier (filed as CELLSNET-42641;CELLSNET-42639;CELLSNET-42638;CELLSNET-42637;CELLSNET-42636) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.

The issues you have found earlier (filed as CELLSNET-42636) have been fixed in Aspose.Cells for .NET 18.6. Please also check the document/article for your reference: https://docs.aspose.com/display/cellsnet/Installation