We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Issues with transparency in Aspose.Slides for Java

I have found issues in PDF conversion results with the latest 18.11 version of Slides for Java library. The issue is related to transparent images.
The previous version 17.8 was working properly.
To reproduce the issue, I’ve attached a ZIP file containing a small java program that generates PDFs from various source PPT files, with one slide only but with different details. The PDFs are generated with both 17.8 and 18.11, in order that you can compare the differences in conversion.
Many thanks in advance.
Regards.

Download ZIP

@renato.mauro,

I have worked with source files shared by you using Aspose.Slides for Java 18.11 and unable to observe any issue. I have also shared my sample code and generated result with you. Please check attachment. Also please share sample code environment details along with generated result so that we may further investigate to help you out. Please visit this link to download files.

Dear Adnan,
I’m running Java using jre1.8.0_191 on Windows 10 64bit. I’ve checked the ZIP file at the link you provided but is missing the source code you used, so I can’t compare it with mine.
At this link I’ve added a converted document only ZIP that can you can download, all done using 18.11.
Thanks, regards.

@renato.mauro,

I have observed your comments. I have shared sample code with you. Also can you please confirm again which version you used on your end because as i can see from your generated result water mark you used Aspose.Slides for java 18.4 on your end. Also i am unable to observe any issue in your result. Can you please share comparison screenshot pointing towards issue so that we may further investigate to help you out.

Presentation presentation = new Presentation(path+"Test_slide_original_solid_fill_transp.pptx");
PdfOptions qualityOptionsConvert = new PdfOptions();
qualityOptionsConvert.setCompliance(PdfCompliance.PdfA1b);      

presentation.save(path+“Test_slide_original_solid_fill_transp.pdf”, SaveFormat.Pdf);

Hello Adnan,
thanks for you code, but as far as I could see you instantiate the PdfOptions but they are not passed as parameter to presentation.save() method (as third parameter). As a result, you are always saving as a normal Pdf, not Pdf/A (and the issue is not coming out).

The version in watermark is 18.4, because I have tested older versions too, but the problem persists (tested down to 18.1).

Could you please change the last line of your testing code with the following:

presentation.save(path+“Test_slide_original_solid_fill_transp.pdf”, SaveFormat.Pdf, qualityOptionsConvert);

then issue should come out, as on image below, that compares the original PPT with the converted PDF:
image.jpg (198.2 KB)

Thanks.

@renato.mauro,

I have worked with the presentation shared by you using Aspose.Slides for Java 18.11.0 and have been able to observe the issue. A ticket with ID SLIDESJAVA-37459 has been added in our issue tracking system to resolve the issue. This thread has been associated with the ticket so that we share notification with you once issue will be fixed.