Free Support Forum - aspose.com

IsVerticalBroken not working properly

I am attempting to use the isverticalbroken property of the table class. It does break the table at a relatively logical position but the next half of the table is not being shown on the following page. Where is the rest of my table going and how do i get it on the next page?
Here is the code im setting for the table

sec = New Section
sec.IsNewPage = True
sec.IsLandscape = True
tab23 = New Table(sec)
tab23.IsVerticalBroken = True
tab23.IsVerticalBrokenInSamePage = False
tab23.IsBroken = True

If I comment the isverticalBroken line I get the entire table going past the right hand border ignoring the margins.
Am i missing something or is this functionality currently broken? I know you’ll ask so attached are 2 pdfs 1 labeled testNotBroken is when I run the code with the line commented out. the other labeled testBroken is with isverticalbroken = true and isverticalbrokenInSamePage = false. The zip contains the code used to generate these files.

Thanks
Ray

Hello Ray,

We are looking into the details of this problem and will reply to you soon. We apologize for your inconvenience.

Meanwhile as a workaround in order to display the table over the same page, set the Landscape orientation of section to true. The file that I've generated is in attachment, please take a look.

sec1.IsLandscape = True

Hi,

I can reproduce the problem at my end, I have logged it as PDFNET-7886 in out issues track system, I will try to fix this problem in about 4 days.

Thanks.

Alex thanks for looking into this issue. Can you provide me with any updates on this issue or when you expect to have a fix available for it?
Thanks
Ray

While that would indeed work on the very simple test code I used to illustrate the issue on my actual application that will not help at all since it is already set to landscape and still running off the RHS of the page.
Thanks for trying

Hello Ray,

Our development team is still working hard to get this issue resolved. We really apologize for the delay and inconvenience that you have been facing in this regard. I've again contacted the team to share the exact ETA for the resolution of this problem.

Your patience and understanding is highly appreciated in this regard.

Hi gnrkrazy,

I have fixed this issue before 3-20, I have sent the moficated code to my colleague, but he need to take some kinds of testing just like testing a production, I will ask my colleague to send you the update as soon as possible.

Thanks.

Thank you very much. Please let me know when this is available I have a client waiting for their report and this is a requirement of the completion.

thanks again
Ray

The issues you have found earlier (filed as 7886) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by forever.

german text not displayed properly in pdf file

german text not displayed properly in pdf file generated using aspose.pdf.dll version 3.6.1.0

Hi,

Thanks for considering Aspose

Can you please share how you are generating the PDF file. Also if possible, please share the code snippet that you are using, so that we can test the scenario at our end.

We apologize for your inconvenience.

hi,

i am using XSL-FO to process xml and the use ASPose PDF Dll to save the result as PDF.But PDF file OPens with 125 % Zoom instead Of 100%.

please let me know the solution to correct this.

Hi.

Thanks for considering Aspose.

You can set the PDF zoom factor value in PDF viewer i.e. Adobe Reader and I’m afraid you cannot specify this information inside the PDF document. To set the Zoom factor, please follow the steps given below

Open Adobe Reader à Select Edit Menu à Preferences à Page Display and in Magnification section, select the value as 100% for Default Zoom.

See the attached screenshot.