Japanese not displaying correctly when going from DOC to PDF


#1

Hi I have version 15.1 of Words for .net. I have many Japanese documents that I need to convert from Word into PDF. When I do though, the punctuation is not handled correctly, since they use special punctuation - often times it is leaving it at the start of a line, instead of wrapping a character down before it.


I tried downloading a new version 16.11 as a trial, to see if it fixes it, but the problem only gets worse. In the newest version the lines do not wrap at all (since in Japanese they jam all the characters together).

What can I do? Is this something that can be fixed.

#2
Hi Vanna,

Thanks for your inquiry. Please note that Aspose.Words requires TrueType fonts when rendering documents to fixed-page formats (JPEG, PNG, PDF or XPS). You need to install fonts on the machine where you're converting documents to Pdf. Please refer to the following articles:

How Aspose.Words Uses True Type Fonts

If you still face problem, please embed the fonts inside your input document and share it here for testing. We will investigate the issue on our side and provide you more information. To embed a TrueType font in a saved document in Microsoft Office Word 2016, follow these steps:

  • First, select the File option from the Word ribbon at the top of the screen.
  • From the options bar on the left-hand side, choose Options.
  • A Word Options window will come up. Select the Save option from the banner on the left-hand side.
  • Under Preserve fidelity when sharing this document select the check box next to Embed fonts in the file. Then click OK.

#3

I was using an Open Type font. I have switched to a True Type Font (MS-Mincho), and it does seem to fix some of the problems. However, it doesn’t fix them all.


I have attached an example that shows what I mean.

- The word doc is how things look before Aspose converts to pdf. Notice the 4th main paragraph and how it doesn’t put the period on it’s own line by itself, but wraps one of the Japanese characters down so it isn’t by itself.

- Now take a look at the three pdf’s (each from different versions of Aspose)

Version 15-1, notice how the period in that paragraph is on it’s own line now.

I downloaded newer versions hoping things would be better, but …

Version 16-4, things get worse, nothing really wraps
Version 16-11, same as 16-4

Thanks for taking a look at this!

#4
Hi Vanna,

Thanks for sharing the detail. We have tested the scenario and have managed to reproduce the same issue at our side. For the sake of correction, we have logged this problem in our issue tracking system as WORDSNET-14586. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

#5

Do you have a time estimate on how long before this fix might be done? This is a production issue for us. We will be renewing our license so we can get the update. Thanks!


#6
Hi Vanna,

Thanks for your inquiry. We try our best to deal with every customer request in a timely fashion, we unfortunately cannot guarantee a delivery date to every customer issue. Our developers work on issues on a first come, first served basis. We feel this is the fairest and most appropriate way to satisfy the needs of the majority of our customers.

Currently, your issue is pending for analysis and is in the queue. Once our product team completes the analysis of your issue, we will then be able to provide you an estimate.

Thanks for your patience and understanding.

#8

I see a message posted in Feb of this year (2019) saying this issue is fixed. However when I click the link to the update it sends me to a downloads page for jasper reports?

I am using Words .Net (not jasper reports).

I wanted to confirm that this bug was really fixed for Words.Net and if so, can I get a link to the correct update / version?


#9

@gaportfolio

We have removed aspose.notifier post. We apologize for your inconvenience.

Unfortunately, your issue (WORDSNET-14586) has not resolved yet. We will inform you via this forum thread once there is an update available on your issue. Thanks for your patience.


#10

Is there any way we could pay to get you to focus on this issue? Right now (and for the past 2 years) we cannot generate PDF documents in Japanese or Chinese because of this issue. We would definitely be willing to upgrade to the newest version if it worked / fixed the problem. Let us know what we can do (if anything) to make this issue a priority.


#11

@gaportfolio

We are looking into your issue. We will get back to you once there is an update available on it. Thanks for your patience.


#12

The issues you have found earlier (filed as WORDSNET-14586) have been fixed in this Aspose.Words for .NET 19.8 update and this Aspose.Words for Java 19.8 update.