Javadoc provided is invalid


When I try to validate the javadoc location in Eclipse it does not work.
It says:
Files ‘package-list’ and ‘index.html’ that are typically available at the root of documention created by the Javadoc tool have not been found.

More detail message from eclipse’s log, if I try to get doc for acceptAllRevisions method for example:

Unknown javadoc format for acceptAllRevisions() {key=Lcom/aspose/words/Document;.acceptAllRevisions()V|Ljava/lang/Exception;} [in Document [in Document.class [in com.aspose.words [in lib/Aspose.Words.jdk16.jar [in Aspose]]]]]

Hi Oliver,

Thanks for your inquiry.

Please ensure you are referencing the correct location, this should be if you are linking to it online or the apidoc directory if you are using it offline.

Could you also test to see if "doc.getNextSibling()" will return the proper documentation when hovered over.



Validation on the online javadoc works, but I still get errors when hovering over methods.
Hovering over class names is ok.

If I hover over “doc.getNextSibling()”, I get :

Java Model Exception: Java Model Status [Unknown javadoc format for getNextSibling() {key=Lcom/aspose/words/Node;.getNextSibling()Lcom/aspose/words/Node;} [in Node [in Node.class [in com.aspose.words [in lib/Aspose.Words.jdk16.jar [in Aspose]]]]]]
at org.eclipse.jdt.internal.core.BinaryMethod.extractJavadoc(
at org.eclipse.jdt.internal.core.BinaryMethod.getAttachedJavadoc(
at org.eclipse.jdt.internal.ui.text.javadoc.JavadocContentAccess2.getHTMLContent(
at org.eclipse.jface.text.TextViewerHoverManager$

Hi Oliver,

Thanks for this additional information.

I was unable to reproduce that issue using Eclipse, those methods worked fine. It did however throw an exception when hovering over the value of an enumeration, which is strange. I will log this and look closer into this behaviour some time.

Futhermore I tried accessing the docs using IntelliJ and encountered no errors. Could you try using a different machine/IDE and see if the issue still remains?

Also note, the link in my previous post should be without any file name.