Free Support Forum - aspose.com

JDK Version


#1

Dear Support,

I checked aspose pdf is compiled using JDK 1.8 and our server is running on JDK 1.7

any compatible version?

thanks


#2

@kuanhuat81

Thanks for contacting support.

You may please download JDK 7 compatible JAR (i.e. aspose-pdf-18.12-jdk17.jar) of Aspose.PDF for Java from available package in Aspose Repository to use it as per your environment.


#3

Dear Asad,

thanks, how about aspose.zip? not available for java?


#4

@kuanhuat81

This is to inform you that Aspose.ZIP is available only for .NET the moment.


#5

hi,

i just purchased a license.

when i tried to download aspose cell i noticed there’s no option for jdk 1.7 like aspose pdf.

but when i checked the manifest file:
Minimum-JDK: 1.6
Bundle-Name: Aspose.Cells for java
Bundle-Version: 19.2.0
Caller-Allowable-Codebase: *
Permissions: all-permissions
Name: Aspose.Cells for java
Specification-Version: 19.2.0
Created-By: 1.8.0_172 (Oracle Corporation)

can i use with jdk 1.7?


#6

@kuanhuat81,

Yes, we provide Aspose.Cells for Java jar compiled on JDK1.6. This jar works fine on any JDK version >= 1.6. And, yes, You can use this library on JDK 1.7, 1.8, 9, 10 and so on.