Free Support Forum - aspose.com

JVM Crash on IBM/AIX

Hello,

We are developing a webservice, that generates ppt slides with aspose. This webservice is deployed on a SAP Netweaver Application Server 7.0 on an IBM / AIX 5.3. (Power PC 64 bit architecture) machine.

When we executed the webservice once, it works fine. But if the webservice is executed repeatedly and/or in parallel, the JVM crashes with a general protection fault.

We have created a java core dump, that indicates, that the crash is caused by aspose. All active threads of the application end at com/aspose/slides/Shape.const(SourceFile:2142(Compiled Code))

For example:

3XMTHREADINFO "SAPEngine_Application_Thread[impl:3]_24" (TID:0x000000011733E400, sys_thread_t:0x00000001172F4350, state:R, native ID:0x00000000006800FF) prio=5
4XESTACKTRACE at com/aspose/slides/Shape.const(SourceFile:2142(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Shape.char(SourceFile:2083(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Rectangle.char(SourceFile:211(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Shape.int(SourceFile:2223(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Presentation.do(SourceFile:3421)
4XESTACKTRACE at com/aspose/slides/Slide.do(SourceFile:644)
4XESTACKTRACE at com/aspose/slides/Presentation.do(SourceFile:1237)
4XESTACKTRACE at com/aspose/slides/Presentation.cloneSlide(SourceFile:1306)

or

3XMTHREADINFO "SAPEngine_Application_Thread[impl:3]_6" (TID:0x0000000116DBCE00, sys_thread_t:0x0000000116D72D90, state:R, native ID:0x00000000004050D5) prio=5
4XESTACKTRACE at com/aspose/slides/Shape.const(SourceFile:2142(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Shape.char(SourceFile:2083(Compiled Code))
4XESTACKTRACE at com/aspose/slides/Rectangle.char(SourceFile:211(Compiled Code))
4XESTACKTRACE at com/aspose/slides/TextFrame.char(SourceFile:813)
4XESTACKTRACE at com/aspose/slides/Shape.getHeight(SourceFile:1796)

The JVM used is J2RE 1.4.2 IBM J9 2.3 AIX ppc64-64 build j9ap64142-20070708

The application works just fine on our Windows XP development system. The error occurs only on the IBM / AIX system...

Do you have any suggestions, that might help to get this application to run under AIX?

I am currently developing a tester application, that will run as command-line application and, hopefully, reproduce this error.

If you need more information (i.e. the full core dump), I can provide this as well...

Hello,

Perhaps you will need the exact product version we use:

Aspose.slides = 1.8.2.0

Aspose.pdf = 2.3.0.0

Aspose.metafiles = 1.2.6.0

Best regards,

Andreas

Hello Andreas,

I’m not sure but looks like a bug in java runtime.
Most probably in jit compiler. Please try to turn it off and write about results.
From our side I can build non-optimized version of aspose.slides for you to test.

Hello,

I have now been able to reproduce the problem with a test application. My next steps will be:

1. I will replace aspose.slides.jar with the most current version

2. I will deactivate jit compiler options and see, what results this creates.

3. I will try the non-optimized version you mentioned

Could you please prepare and send me the non-optimized version of aspose.slides, that you mentioned, so that I can prepare the third test?

Best regards,

Andreas

Andreas,

That is latest version of aspose.slides without any optimizations.

Hello Alexey,

I have now finished my tests with my test application and have good results:

1. Replacing the aspose.slides.jar with the latest version (with optimization) did not succeed
2. Even after turning off the JIT compiler, the problem persisted
3. After replacing the aspose.slides.jar with the version you provided (without optimization) the testcase was successfull!

Tomorrow I will test the application with a load-test to verify the solution. I hope, that this time the load-test will be successful and performant enough…

Thank you for your quick and helpful support!

Best regards,
Andreas

Hello Alexey,

The load test with the unoptimized version of aspose was successful!.

I have one last request:

Would it be possible to include the unoptimized version of the aspose.slides.jar in the general distribution? It would be awkward to have to request the unoptimized version for every release of aspose.slides...

Best regards,

Andreas