Free Support Forum - aspose.com

JVM failed

Hi,

I wanted to test the latest Aspose.Cells (7.3.0) for JDK 1.5 but I got following error:

#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0xf6d55649, pid=29548, tid=4136811376
#
# JRE version: 6.0_30-b12
# Java VM: Java HotSpot™ Server VM (20.5-b03 mixed mode linux-x86 )
# Problematic frame:
# V [libjvm.so+0x403649] unsigned+0xe9
#
# An error report file with more information is saved as:
# /home/emisia/projects/filters3-trunk/gs4tr-filters-msoffice/hs_err_pid29548.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#

I am using Ubuntu 10.4 (64 bits) + JDK 1.6.
Test was run as JUnit test from Eclipse.

Can someone tell me why this happening?

Thanks,
Zeljko

Hi,

Thanks for your posting and using Aspose.Cells for Java.

Please try setting java.awt.headless=true before running your code and see if it gets crashed or not.

Please note the red line below.

Java


System.setProperty(“java.awt.headless”, “true”);

CellsHelper.setFontDir(fontDir);

Workbook book = new Workbook(“2.xls”);

Worksheet sheet = book.getWorksheets().get(0);

PageSetup pageSetup = sheet.getPageSetup();

pageSetup.setOrder(PrintOrderType.OVER_THEN_DOWN);

book.save(“2.pdf”);

Thanks for helping me. It is working now, but does this mean that my application will not be able to use mouse or keyboard if I set this property?

Hi,

Thanks for your feedback.

It’s good to know that above post was helpful for you. Are you getting any problems with the use of mouse or keyboard?

We will look int to this issue and give you some advice asap.

Hi,

Thanks for using Aspose.Cells for Java.

Commonly the requirement of using java.awt.headless option is because of the fact that display device, keyboard, or mouse is lacking in the system configuration where your application is running. So, please make sure you can use other java.awt functions in headful mode firstly.

If you can use other headful features but get JVM crashed when using cells component, please provide us more information about your system and we will make further investigation. Also you can add this option to run your headful features again to test whether it infects those features.

Hi,

I am getting exactly the same error as in initial post after I’ve updated Aspose Cells to 7.3.0. Once I revert to older version 7.0.1 my application is functioning properly.

Is there any way to fix it without disabling some of the properties? Is there any graphics involved in new jar? Application is working fine with older version of Aspose Cells.

I am working in Linux/CentOS.
JDK 1.6, Netbeans IDE 6.7.1

Hi,

Thanks for your posting and using Aspose.Cells for Java.

We checked this issue and found “JVM crash” is related to calling com.sun.FontManager.getFontPath().

So, we think it is a bug of OpenJDK not our product.

We
are working to provide a new interface which will help the clients to
manage fonts. Using this interface, clients can use our product without
setting java.awt.headless.

The above interface has been logged in our database with the issue id: CELLSJAVA-40227


Hi,

We have looked into this issue further.

We will add one new JVM option such as -DAspose.Cells.Disable=SunFontManager to avoid this crash instead of -Djava.awt.headless.

We will provide you a fix soon after implementing this.

Hi,

Please download and try this fix: Aspose.Cells for Java v7.3.0.4

Please try jvm option Aspose.Cells.Disable=SunFontManager instead of java.awt.headless=true to avoid the jvm crash issue.

The issues you have found earlier (filed as CELLSJAVA-40227) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

Hi,

I am getting exactly the same error as in initial post after I’ve updated Aspose Cells to 7.3.4 and try with 7.3.1. version, too.


Use Ubuntu 10.4 and JDK 1.6.

Thanks,
Bojan
bjerinic:
Hi,

I am getting exactly the same error as in initial post after I've updated Aspose Cells to 7.3.4 and try with 7.3.1. version, too.

Use Ubuntu 10.4 and JDK 1.6.

Thanks,
Bojan
Hi,

Please use the following code to get rid of this error. You need to add red line at the very start of your code.

Java
System.setProperty("java.awt.headless", "true");
CellsHelper.setFontDir(fontDir);
String filePath = "c:/samples/yoursourcefile.xls";
Workbook book = new Workbook(filePath);
book.save(filePath + ".out.pdf");

Hi,

thanks for reply. But this setting of System property is not good for me, cause Headless mode is a system configuration in which the display device, keyboard, or mouse is lacking. In some of early post you say: " try jvm option Aspose.Cells.Disable=SunFontManager". What does it mean and how it works, is something as setting of system property(jvm) "Headless" on true in back?

Do you plan some implementation without Headless mode?

Many thanks,
Bojan

Hi,

Thanks for your posting and using Aspose.Cells for Java.

For your situation, please use property “Aspose.Cells.Disable” with value ”SunFontManager” instead of property “java.awt.headless”. And “Aspose.Cells.Disable” property will not change the headless property. The usage of ”Aspose.Cells.Disable” is same with other properties including “java.awt.headless”:

java –DAspose.Cells.Disbale=SunFontManager …